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概要：YASARA Structure (Version 24.10.5)により、mixed-solvent MD の実行方法をチュートリアル形式で説明します。
本チュートリアルでは、HIV-1 プロテアーゼの構造（PDB ID:1PRO）について、イソプロパノール/水の共溶媒（10% 

v/v）中での分子動力学シミュレーションの実行方法を例に説明します。 

 

1. はじめに 

 本チュートリアルでは、共溶媒を用いた分子動力学シミュレーション（mixed-solvent MD）の実行方法について説明しま

す。YASARA で mixed-solvent MD を実行するには、シミュレーションセル内を溶媒で満たした状態のファイル

（[YourStructure]_solvent.sce）を準備し、付属マクロファイル（md_run.mcr や md_runfast.mcr）を一部編集したファイルを用

意して実行します。 

 本チュートリアルでは、PDB ID:1PRO を用いて、イソプロパノール/水の共溶媒（10% v/v）中での分子動力学シミュレー

ションの実行方法を例として、操作方法を順に説明します。 

※チュートリアル中、ファイル名に[YourStructure]と記載することがあります。この文字列はマクロターゲット（入出力フ

ァイルの共通の接頭辞）となる任意の文字列を意味しています。同一プロジェクトのファイルには、共通の文字列を使用す

るようにしてください。 

 

2. 実行手順 

2.1 作業ディレクトリの作成 

シミュレーションを実施するにあたり入出力ファイルを格納するディレクトリ（フォルダ）を新規に作成しておき

ます（Windows ではエクスプローラ、Linux では mkdir コマンド等を使用）。作成場所やファイル名は任意で問題あり

ませんが、YASARA 上で表示が乱れるため、日本語を含まないようにしてください。 

 

例 

(Windows) C:¥Users¥username¥Desktop¥YASARA_DATA¥tuto_mixed-solvent-md 

(Linux)  /home/username/YASARA_DATA/tuto_mixed-solvent-md 

 

2.2 溶質構造の読み込み 

メニューから File > Load > PDB file from Internet を選択し、PDB ID に「1PRO」と入力し、OK をクリックして PDB 

ファイルをダウンロードすると、画面上にタンパク 3D 構造が表示されます。 

 

2.3 クリーニング処理 

❑ 不要分子の削除 

タンパク質以外の不要な分子を削除します。画面右側の SCENE CONTENT から構成分子を確認します。今回

は下 3 つ分の分子を削除します。 



 

Figure 2-1 オブジェクトの構成分子の確認 

 

メニューから Edit > Delete > Molecule を選択し、Sequence 列の分子のリストから、Ctrl キーを押しながら不要

な分子を選択し（下図参照）、OK をクリックします。 

 

Figure 2-2 Delete の実行 

 

❑ クリーニング処理（Clean コマンド） 

メニューから Edit > Clean > All を選択し、水素付加などのクリーニング処理を行います。 

 

❑ 水素結合ネットワークの最適化（OptHyd コマンド） 

メニューから Edit > Add > hydrogens to: Object & optimize を選択し、Sequence 列または Name 列から「1pro」を

クリック（対象オブジェクトを選択）し、OK をクリックします。 

 

2.4 シミュレーションセルの設定 

  原子の周囲 10Å、立方体に設定してセルを作成します。（サイズに指定はありませんが、YASARA ではこの設定

が標準的に使用されています。） 

メニューから、Simulation > Define simulation cell をクリックし、設定画面を開きます。Shape: Cube, Extend:10.0 A に設

定し、「around all atoms.」（全ての原子の周囲）をクリックします。 



 

Figure 2-3 シミュレーションセル設定 

 

 

Figure 2-4 シミュレーションセルの設定例 

 

2.5 力場の設定 

 溶媒を準備するための力場を設定します。今回は例として AMBER14 を使用します。 

メニューから Simulation > Force field を選択し、リストから力場を選択（例：AMBER14）し、「OK, and if~」（デフォ

ルトパラメータを使用）をクリックします。 

 

Figure 2-5 力場の設定 

 

現在の力場は、操作画面の右下や、HUD の SIMULATION PARAMETERS（Ctrl+I キー）などから確認できます。 



 

Figure 2-6 現在の力場の確認 

 

2.6 セルの中和（Experiment neutralization） 

メニューから、Options > Choose experiment > Cell neutralization and pKa prediction を選択し、次に表示される画面で

パラメータを設定します。 

・Browse：pKa 予測結果の出力先を選択します。（（1）で作成した作業ディレクトリを指定） 

・Filename to store pKa predictions：pKa 予測結果の出力ファイル名を入力します。（例：1por.pka） 

・Cation：Na、Anion：Cl を選択 

その他はデフォルト値のまま実行しますが、pH やイオン濃度などを変更することもできます。設定できたら OK

をクリックして実行します。 

 

Figure 2-7 中和 Experiment の設定画面 

 

2.7 水分子の削除 

 次に溶媒を準備するため、メニューから Edit > Delete > Waters を選択してセル内の水分子を削除します。この時点

で、Obj 3「Water」内にはイオンのみが残っています（セルを中性に保つために必要なので残しておきます）。 

わかりやすくするために、オブジェクト名を変更しておきます。SCENE CONTENT の Name 列で Obj 3「Water」を右

クリック、「Name」を選択後、入力欄に「Ions」などと入力して OK をクリックします（任意）。 

 

2.8 溶媒の加重密度の計算 

ここで、溶媒の体積パーセント濃度（% v/v）に従って各溶媒の加重密度を計算しておきます。主要な溶媒の密度

（298 K in g/ml）については、YASARA ユーザーマニュアルの PressureCtrl コマンドページに記載されています（イ



ソプロパノール：0.7827 g/ml、水：0.997 g/ml）。ここでは、10% v/v のイソプロパノール/水の共溶媒について、MD

用マクロのデフォルト設定（298 K、1.0 bar）に合わせて溶媒密度を計算します。 

 

 イソプロパノールの加重密度 

0.7827 × 0.1 = 0.07827 (𝑔/𝑚𝑙) 

 水の加重密度 

0.997 × 0.9 = 0.8973 (𝑔/𝑚𝑙) 

 

2.9 溶媒分子の構築と配置 

本チュートリアルでは SMILES 文字列を使用して溶媒分子を構築しますが、予め用意しておいたオブジェクトファ

イルを読み込む、分子ビルダー（Help > Play help movie > 4.1. Building small molecules 参照）を利用するなど、お好み

の方法で操作画面上に溶媒分子のオブジェクトを作成またはロードしてください。 

 

❑ イソプロパノール分子の構築 

SMILES 文字列を使ってイソプロパノール分子を構築します。メニューから Edit > Build > Molecule from 

SMILES string を選択し、「CC(O)C」と入力して OK をクリックします。構造が不自然な場合などは、必要に応

じて Clean 処理（Edit > Clean > Object）を行ってください。 

続いて、任意ですが、わかりやすくするためにオブジェクト名を変更しておきます。SCENE CONTENT の

Name 列で Obj 4「SMILES」を右クリックし、コンテキストメニューから「Name」を選択後、入力欄に

「Isopropanol」と入力して OK をクリックします。 

 

❑ イソプロパノール分子の配置 

 メニューから Simulation > Fill cell with… > Copies of an object を選択後、Object 4 の「Isopropanol」を選択して

OK をクリックします。 

続いて、設定ダイアログから各種設定を行います。2 つ目のチェックボックスにチェックを入れ、手順 2.8 で計

算した密度を入力します。その他、必要に応じてパラメータを調整してください。ここでは例として、一番下

の「Randomize object orientation by（方向のランダム度合い）」を 50％に変更して実行します。 

 

 

Figure 2-8 FillCell コマンドのパラメータ設定 

 

 

 

 

 

 

 

 



 

これで、イソプロパノール分子をセルに配置できました。 

 

Figure 2-9 溶媒の配置例（イソプロパノール） 

 

❑ 溶媒オブジェクトを一時的に取り除く 

 次の溶媒を追加するためのスペースを確保するため、作成した溶媒オブジェクトを一時的に Soup から取り除

いておきます。メニューから Edit > Remove > from soup: Object を選択し、選択ダイアログから先ほど作成した

Obj 4 の「Isopropanol」を選択して OK を押します。 

 

 

Figure 2-10 溶媒オブジェクトの Remove 

 

続いて、同様の操作を繰り返して次の溶媒分子（水分子）を構築・配置します。 

❑ 水分子の構築 

メニューから Edit > Build > Molecule from SMILES string を選択し、「O」と入力して OK をクリックします。 

任意でオブジェクト名を変更しておきます。SCENE CONTENT の Name 列で Obj 5「SMILES」を右クリック

し、コンテキストメニューから「Name」を選択後、入力欄に「Water」と入力して OK をクリックします。 

 

❑ 水分子の配置 

 メニューから Simulation > Fill cell with… > Copies of an object を選択後、Object 5 の「Water」を選択して OK

をクリックします。 

先ほどと同じように、手順 2.8 で計算した密度を入力し、Randomize object~を 50%に設定しておきます。 



 

Figure 2-11 FillCell コマンドのパラメータ設定 

 

 

Figure 2-12 溶媒の配置例（水） 

 

（混合する溶媒分子がさらにある場合は、「溶媒分子を一時的に取り除く」からの操作を繰り返して準備してください。） 

 

❑ 取り除いた溶媒オブジェクトを戻す 

 最後に、取り除いていた溶媒分子（イソプロパノール）を Soup に戻します。Edit > Add > to sopu: Object を選

択し、選択ダイアログから Obj 4 の「Isopropanol」を選択して OK を押します。 

 

Figure 2-13 溶媒オブジェクトの配置例（イソプロパノール/水） 



2.10 溶媒オブジェクトのエネルギー最小化 

 続いて、タンパク質を固定し、周りに配置した溶媒オブジェクト部分のエネルギー最小化を行います。 

❑ 溶質（タンパク質）オブジェクトの固定（Fix） 

メニューから Simulation > Fix > Object を選択し、溶質オブジェクト（1pro）を選択して OK を押します。（固

定した部分は黄色で表示されます。） 

 

❑ 溶媒のエネルギー最小化 

メニューから Option > Macro & Movie > Play macro をクリックし、マクロファイル em_run.mcr を選択してエ

ネルギー最小化を実行します。（エネルギー最小化の詳細については、別資料のチュートリアルをご参照くださ

い。技術情報ページ：https://www.affinity-science.com/yasara-tech/） 

 

Figure 2-14 溶媒オブジェクトのエネルギー最小化（黄色部分の溶質は Fix） 

 

❑ 溶質（タンパク質）オブジェクトの固定解除 

 メニューから Simulation > Free > All を選択して固定をすべて解除します。 

 

2.11 Sceneファイルの保存 

 File > Save as > YASRA Scene を選択し、手順 2.1 で作成した作業ディレクトリに「1pro_solvent.sce」として保存し

ます。 

ファイル名は、「[YourStructure]_solvent.sce」のように指定してください。[YourStructure]部分は任意の文字列を使用し

てください（上の例では「1pro」を使用）。[YourStructure]部分は後ほどマクロターゲットに指定します。 

 

Figure 2-15 初期構造の保存（[YourStructure]_solvent.sce） 

 



シミュレーションセルを溶媒で満たした状態の Scene ファイルを[YourStructure]_solvent.sce として作業ディレクトリ

に保存し、マクロターゲットに指定しておくと MD 計算用のマクロファイル（md_run や md_runfast）実行時、自動

的に読み込まれてシミュレーションに使用されるようになっています。 

 

Figure 2-16 md_run.mcr より一部抜粋 

 

2.12 マクロファイル（md_run）の編集・保存 

 次に、マクロファイル（md_run）の圧力制御の設定を編集しておきます。マクロファイル md_run.mcr を作業ディ

レクトリなどにコピーし、パラメータセクション（=で挟まれた部分）内の以下の行を探し、行頭の「#」を削除して

アンコメントします。（圧力制御（pressurectrl）を、デフォルトの「SolventProbe」から「Manometer1D」に変更しま

す。

 

Figure 2-17 pressurectrl の編集例（md_run.mcr より一部抜粋） 

 

その他、必要に応じて各種パラメータを調整し、上書き保存します。任意で編集済みのファイル名を変更しておきま

す（例：md_run_tuto.mcr など）。 

※pressurectrl の詳細については、補足の「3.3Pressurectrl（圧力設定）について」をご覧ください。 

※マクロファイルの編集方法や各種パラメータについてより詳しく知りたい場合は、分子動力学計算のチュートリア

ル資料をご参照ください。（技術情報ページ：https://www.affinity-science.com/yasara-tech/） 

 

2.13 マクロファイルの実行 

 上記で準備したマクロファイルを実行します。 

❑ ターゲット設定 

 Options > Macro & Movie > Set target を選択し、Browse から手順 2.11 で保存した Scene ファイルを指定、右側

の Remove オプションで「from underscore（アンダースコア以降を除く）」にチェックを入れて OK。 

 

Figure 2-18 マクロターゲット設定画面 



❑ マクロ実行 

 Options > Macro & Movie > Play macro を選択し、Browse から手順 2.12 で保存した編集済みマクロファイルを

指定し、OK を選択して実行します。 

 

Figure 2-19 マクロファイルの選択画面 

 

 

Figure 2-20 MD 計算実行中画面 

 

  



3. 補足・参考情報 

3.1 その他の初期構造ファイルの準備方法 

3.1.1 NaCl水溶液から準備する方法 

 md_run.mcr（md_runfast.mcr）は、デフォルトで実行するとシミュレーションセルに 0.9% NaCl 水溶液が充填されてシミ

ュレーションが開始します。この構造ファイルは、作業ディレクトリに「[YourStructure]_water.sce」として保存されるので、

イオンを置換するだけでよい場合などは、このファイルを編集して利用する方法もあります。以下に、２つの例を用いて実

行手順を説明します。 

 

例１） NH4Cl 水溶液の準備方法 

 溶質の構造ファイルを用意し、通常の手順で md_run.mcr を実行する 

 計算用ディレクトリに[YourStructure]_water.sce ファイルが作成されたら、シミュレーションを停止する 

（Simulation > Simulator > Pause） 

 画面をクリアし、作成された[YourStructure]_water.sce ファイルを読み込む 

 Na を N に置換する 

（Edit > Swap > Atom を選択し、セレクト画面で Name リストから Na を選択後、次の画面で Element リ

ストから Nitrogen を選択し OK） 

 窒素 N に水素を付加する 

（Edit > Clean > Object を選択し、窒素が属するオブジェクト(例：Water）を指定して OK） 

 [YourStructure]_water.sce としてファイルを作業ディレクトリに保存し、ディレクトリ内のその他のファ

イルを削除する 

 前述の実行手順手順 2.12 から同様に操作する 

 

例２） NaCl / KCl 水溶液の準備方法（Na と K イオンが等量の場合） 

 例１と同様に操作し、初期（0.9% NaCl 水溶液）の[YourStructure]_water.sce ファイルを入手して読み込

む 

 次のマクロをコンソールに入力して実行する。 

nalist()=ListAtom Element Na 

for i=1 to count nalist/2 

SwapAtom (nalist(i)),K 

pass 

（コンソールに直接貼り付けする場合、繰り返し処理を適切に終了する必要があります。上記の例では

何もしないダミーの pass コマンドを使用。） 

 [YourStructure]_water.sce としてファイルを作業ディレクトリに保存し、ディレクトリ内のその他のファ

イルを削除する 

 前述の実行手順手順 2.12 から同様に操作する 

 

3.1.2 水以外の単一の溶媒を使用する方法 

 Mixed solvent MD ではありませんが、単一の水以外の溶媒で MD シミュレーションを実行したい場合は、原子に密度情報

を追加した溶媒分子の構造ファイルを「[YourStructure]_solvent.yob」として作業ディレクトリに保存しておき、マクロ内の

圧力設定を調整して実行します。具体的な手順は以下になります。 

 

 溶媒分子を構築し、必要に応じて Clean 処理（Edit > Clean > All）を行う 

SMILES 文字列を使用したり、分子ビルダー（Help > Play help movie > 4.1. Building small molecules 参照）を

利用するなどして溶媒分子を用意してください。 

 原子のプロパティに溶媒密度(g/ml)情報を設定する 

Edit > Number > Property value > 選択ダイアログで All を選択するなどして溶媒オブジェクトを指定してく

ださい。続いて、Property の入力画面に溶媒の密度(g/ml)を入力します。（ユーザーマニュアルの PressureCtrl



コマンドページに一般的な溶媒密度の一覧表があります。） 

 溶媒分子のオブジェクトファイルを「[YourStructure]_solvent.yob」として作業ディレクトリに保存します。 

（File > Save as > YASARA Object） 

 前述の実行手順手順 2.12 から同様に操作する 

※正確な密度がわかっている場合、マクロ中の圧力設定は溶媒の残基名や密度を編集して'SolventProbe'のま

ま実行することもできます。 

 

3.1.3 シミュレーションセルに溶媒を充填したファイルを持っている場合 

 既にシミュレーションセルに溶媒が充填されている（エネルギー最小化などの処理済みの）構造ファイルを持っている場

合は、溶質となる構造をセルの中心に配置し、以下のようなコマンドを実行して溶質と重なる溶媒分子を削除して

「[YourStructure]_solvent.sce」を用意してください。その後は、前述の手順 2.12 から同様に操作してシミュレーションを実

行してください。 

 

コマンド例：DelRes HOH with distance<2 from !HOH   （溶媒の残基名が「HOH」の場合の例） 

 

 

3.2 Pressurectrl（圧力設定）について 

 MD シミュレーションの圧力設定（Pressurectrl コマンド）についてまとめます。詳細について知りたい場合は、ユーザー

マニュアルの Pressurectrl コマンドページをご覧ください。 

Pressurectrl コマンドを設定すると、設定した圧力に達するまでシミュレーションセルのサイズを調整します（変更する軸を

オプションで指定することもできます。）。圧力制御の方法は大きくわけて SolventProbe と Manometer の２種類があります。 

 

 SolventProbe モード 

このモードでは、密度を測定し、設定した密度になるようにセルのサイズを等方的に変更・調整します（セル

の大きさは変化しますが形状は保たれます）。溶媒の正確な密度がわかっている場合に使用できます。このモー

ドは最も高速ですが、溶質が溶媒に完全に埋め込まれている場合にのみ使用できます。  

SolventProbe モードに設定する場合は、Name パラメータで溶媒分子の残基名を指定し、Density パラメータで

溶媒の密度を設定します。 

コマンド例：PressureCtrl SolventProbe,Name=HOH,Density=0.997 

 

混合溶媒でシミュレーションを行う場合は、実験値とシミュレーションの溶媒密度に誤差が生じる可能性があ

るため、次の Manometer モードの使用が推奨されます。混合溶媒でも SolventProbe モードを使用したい場合は、

まず、溶質を除いて混合溶媒のみを Manometer モードに設定してシミュレーションし、実際の密度を測定して

ください(HUD の SIMULATION PARAMETERS から確認できます)。また、上記の通り、溶媒分子を残基名で指

定するため、全ての溶媒分子に同じ残基名を設定しておきます。その上で、md_run.mcr ファイルの「density=」

や「pressurectrl=」の内容を編集して MD シミュレーションを実行してください。 

 

 Manometer モード 

 このモードでは、圧力を設定し、設定した圧力になるようにセルのサイズを変更・調整するので、正確な密度

がわからない場合も使用できます。Manometer モードには、1D、2D、3D の３種類があります。各モードの圧力

の計算式などの詳細は、ユーザーマニュアルをご覧ください。コマンド実行時には、密度を使用せずに、圧力を

指定します。 

コマンド例：PressureCtrl Manometer1D,Pressure=1 

 

➢ Manometer1D（本チュートリアルで利用） 

全体の圧力をスカラー値として計算します。全ての軸（X,Y,Z）に対して同じスケーリング係数を使用する

ため、セルの形状（例えば立方体）自体は変化しません。SolventProbe モードと同じく、溶質が溶媒に完全

に埋め込まれている場合に使用します。 



➢ Manometer2D 

X 軸と Z 軸の平均圧力を計算し、セルサイズを調整します。X 軸と Z 軸は同じスケーリング係数を使用し

ますが、Y 軸は独立して処理されます。XZ 平面の形状（例えば正方形）は保持されるので、膜が XZ 平面

に平行に配置されている場合、その形状を保持することができるため、このモードは膜タンパク質のシミ

ュレーションに最適です。（md_runmembrane.mcr のデフォルト設定となっています） 

➢ Manometer3D 

X, Y, Z 軸ごとに圧力を計算し、各軸はそれぞれ異なるスケーリングがなされます。（セルの形状が変化し

ます。）タンパク質結晶のシミュレーションなど、溶質がセル全体に広がる場合（溶媒が少ない場合）に使

用します。 

 

 

3.3 ユーザーマニュアルの関連ページについて 

共溶媒を使用した MD シミュレーションの実行手順については、YASARA ユーザーマニュアル（Help > Show user manual）

の、「FillCell」コマンドページ（以下）に記載されています。 

Commands - Tell YASARA what to do > Index - All commands in alphabetic order > FillCellObj - Fill simulation cell with object 

 

圧力制御モードや一般的な溶媒の密度の表は、ユーザーマニュアル「PressureCtrl」コマンドページに記載されています。 

Commands - Tell YASARA what to do > Index - All commands in alphabetic order > PressureCtrl - Set pressure control 

 

MD シミュレーションの基本的な実行手順やヒントについては、ユーザーマニュアルの以下のページをご覧ください。 

 Recipes - Perform complex tasks > Run a molecular dynamics simulation 

 

 

3.4 その他の参考資料 

分子動力学計算やエネルギー最小化の詳細については、弊社ウェブサイトにてチュートリアルを公開しています。その他

技術情報については、ブログ記事や FAQ をご参照ください。 

 

YASARA 日本語チュートリアル 

https://www.affinity-science.com/yasara-tutorial 

  

Affinity Science Blog/.org 

https://www.affinity-science.org/ 

 

YASARA よくある質問 

https://www.affinity-science.com/yasara-faq/ 

 

以上 

https://www.affinity-science.com/yasara-tutorial
https://www.affinity-science.org/
https://www.affinity-science.com/yasara-faq/
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