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YASARAチュートリアル 

低分子ビルディングモードを利用した分子構築 
 

株式会社アフィニティサイエンス 
 

 

概要：YASARA Structure (Version 25.12.1) による、低分子ビルディングモードを利用した分子の構築方法について
チュートリアル形式で説明します。 

 

1. はじめに 

 YASARA には、インタラクティブに分子の構築ができる、低分子ビルディングモードが備わっています。本チュートリ

アルでは、この機能を利用し、以下の 4 つの医薬品化合物を実際に構築しながら、低分子の構築方法について説明します。

また、後半には、構築した分子の調整と最適化の方法についても紹介します。構築・最適化した分子は、ドッキングシミュ

レーションのリガンドなどに利用することができます。 

 

▪ 本チュートリアルで構築する 4 つの医薬品化合物 

 

化合物名（英語） 構造 SMILES 学習のポイント 

アスピリン 

（Aspirin） 

 

CC(=O)OC1=CC=CC=C1C(=

O)O 

置換基パーツを用いた基本的な

構築 

フロセミド 

（Furosemide） 
 

C1=COC(=C1)CNC2=CC(=C(

C=C2C(=O)O)S(=O)(=O)N)Cl 

類似の置換基パーツを代用した

分子構築と原子の置換 

ジアゼパム 

（Diazepam） 

 

CN1C(=O)CN=C(C2=C1C=C

C(=C2)Cl)C3=CC=CC=C3 

縮合環の構築と結合次数の変更 

チオトロピウム 

（Tiotropium） 

 

C[N+]1([C@@H]2CC(C[C@

H]1C3C2O3)OC(=O)C(C4=C

C=CS4)(C5=CC=CS5)O)C 

架橋の構築と繰り返し操作のシ

ョートカット 
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3 

 

2. 低分子ビルディングモード 

  

低分子ビルディングモードは、画面上で対話的に分子を構築できる機能で、YASARA Model 以上のグレードでご利用いた

だけます。 画面上部のアイコン列左端にある六角形のアイコン（    ）をクリックすると「低分子ビルディングモード」

に切り替わり、分子の構築が可能になります。再度アイコンをクリックすると、通常の操作モードに戻ります。この状態で

は、キー操作も通常と異なり、分子構築用のキー割り当てとなります。画面下部から、53 種類の置換基パーツ（次ページを

参照）を利用でき、複雑な化合物を簡単に構築することができます。 

 

置換基パーツの一覧画面の左上には、青色のピンアイコンがあり、これをクリックすると常時表示の ON/OFF が切り替わ

ります。デフォルトでは常時表示が ON になっていますが、クリックして OFF にすると、カーソルを画面下部に動かした

ときのみパーツの一覧が表示されるので、画面を広く使いたい場合に便利です。  

 

 

分子ビルディングモード 
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❑ 分子ビルディングモードで利用可能な置換基パーツの一覧 
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2.1 基本操作 

❑ 分子ビルディングモードへの切り替え 

上部のメニューバーの右側にある六角形のアイコン（  ）をクリックすると分子ビルディングモードが有効になり

ます。再度クリックすると通常モードに戻ります。 

 

❑ 置換基パーツの利用 

画面下部に表示されている置換基パーツをクリックすると、操作画面に選択した構造が追加されます。  

置換基についている青や赤の丸いマークは接続部分を表していて、どこにも接続していない場合、この部分には自動

で水素が付加されます。 

 

①操作画面で原子をクリックし、マークした状態（原子の周りにハイライトが表示）で②下部の置換基パーツをクリ

ックすると、丸いマークの接続部分で結合します。 

 

 

❑ コンテクストメニューによる操作 

原子をクリックしてマークし、右クリックするとコンテクストメニューが開きます。原子の置換（Swap > Atom）

や結合の形成（Add > Bond）などの操作をこのコンテクストメニューから実行することもできます。 

 

結合箇所が複数ある場合は丸いマークが異なる

色で示されており、カーソルを合わせてクリッ

クすることで、接続部位を選択できます。 

①接続したい原子をマーク（クリック） 

②接続したい置換基を選択 
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2.2 キー割り当て一覧 

分子ビルディングモードでは、インタラクティブな分子構築を可能にするため、通常と異なるキーの割り当てがなされて

います。1 つの原子をマークしている状態では、対応するキーを押すことで、原子を置換できます。2 つの原子をマークし

た状態では、原子間の結合次数の変更や、原子間のブリッジの作成ができます（キーの表記は便宜上大文字としていますが、

Shift キーを併用する必要はありません）。 

 

❑ 分子ビルディングモードのキー操作 

 

1 つの原子をマークしている場合 

H 原子を「水素(hydrogen)」に変更 

C 原子を「炭素(carbon)」に変更 

N 原子を「窒素(nitrogen)」に変更 

O 原子を「酸素(oxygen)」に変更 

F 原子を「フッ素(fluorine)」に変更 

P 原子を「リン(phosphorus)」に変更 

S 原子を「硫黄(sulfur)」に変更 

I 原子を「ヨウ素(iodine)」に変更 

 

2 つの原子をマークしている場合 

1 原子間の結合次数を「1」に変更 

2 原子間の結合次数を「2」に変更 

3 原子間の結合次数を「3」に変更 

4 原子間の結合次数を「4」に変更 

5 原子間の結合次数を「1.5」に変更 

C 原子間に炭素ブリッジを作成 

N 原子間に窒素ブリッジを作成 

O 原子間に酸素ブリッジを作成 

P 原子間にリンブリッジを作成 

S 原子間に硫黄ブリッジを作成 

 

その他の操作※ 

T（TypeBond コマンド） 結合次数の自動再割り当てを行う 

L（Clean コマンド） Clean 処理を行い、現在の pH に合わせて結合次数・プロトン化状態を調整する 

Delete（Del コマンド） マークした原子を削除 

※原子をマークしている状態では、TypeBond はマークした残基のみ、Clean はマークしたオブジェクトのみがコマンドの対

象となる。Delete キーの操作は通常モードでも共通。 

 

 

 なお、通常モードでのキー操作については、YASARA ユーザーマニュアル（Help > Show user manual）の [Essentials > How 

to use keys, mouse and touch gestures] の項目にまとめられていますので、そちらをご参照ください。 

  



7 

 

3. 分子の構築例 

それでは、低分子ビルディングモードを使って、4 つの医薬品分子（アスピリン、フロセミド、ジアゼパム、チオトロ

ピウム）を実際に構築していきます。ここでは構築手順の一例をご紹介しますが、必ずしもこの手順に従う必要はなく、

手順の順序を変えたり、異なる置換基パーツを使用したりして構築することもできます。低分子ビルダーで構築した構造

は、原子同士が衝突していたり、結合長や結合角などのジオメトリが不適切であったりする場合があるので、この後に構

造の最適化を行う必要があります。構造の調整や最適化については、次のセクション【4. 分子構造の調整と最適化】で紹

介します。 

 

 

 

 

 

【分子構築時の推奨設定】 

分子モデルの作成にあたっては、以下の手順で結合次数を可視化しておくと作業がスムーズです。なお、本操作は画

面上に分子などのオブジェクトが表示されている状態で実行してください（オブジェクトが存在しない場合、[Bonds]メ

ニューを選択することができません）。 

 

1. 分子のスタイルを F2 キーで Ball & Stick に設定 

2. [View > Color > Bonds] を選択し、[Order] を選択して[OK] 

 

これで、原子間の結合を結合次数に応じた配色で表示することができます。結合次数の配色は以下の通りです。 

 

 

 

 

【Tips】表示スタイルのパラメータ調整 

 表示モデルの球の大きさや棒の太さなどのパラメータは、メニューの [View > Style atoms > parameters] から調整する

ことができます。 
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3.1 アスピリン（Aspirin） 

 はじめにアスピリンを作成してみます。アスピリンは、ベンゼン環、カルボキシ基、エステルの 3 つのパーツに分けられ

るので、以下の手順で構築していきたいと思います。 

 

 

 

 

1) フェニル基を構築 

画面下の置換基の一覧から、「Unsaturated rings」カテゴリの

「Phenyl」をクリックします。 

 

 

 

※本チュートリアルではここで、前ページに記載した【分子構築時

の推奨設定】を行っています。必須ではありませんが必要に応じて

設定して下さい。 

 

2) カルボキシ基を接続 

ベンゼン環の水素原子を 1 つクリックしてマークします。 

 

 

 

置換基の一覧から「Oxygen」カテゴリの「Ester」の青い丸●を

クリックします。 

 

【Point】 

▪ 接続点が複数ある場合は、カーソルを合わせることで接続部位

を指定できます。 

▪ もう一方の接続点には水素が付加し、自動でマークされます。 
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3) エステルを接続 

先ほど構築したカルボキシ基の隣の水素をマークします。 

 

 

 

置換基の一覧から「Oxygen」カテゴリの「Ester」の赤い丸●を

クリックします。 

 

 

 

4) 末端の水素をメチル基に置換 

前の手順でエステルの末端の水素がマークされた状態になって

いるのを確認します。 

（マークを解除してしまった場合は水素をクリックして再度マ

ークしてください） 

 

 

キーボードの[C]キーを押して炭素（メチル基）に置換します。

（表記は便宜上大文字としていますが、Shift キーを併用する必

要はありません。以降の操作も同様です。） 

 

 

【Point】 

原子をマークし、原子が割り当てられたキーを押すとその原子に置

換できます。 

これでアスピリンの完成です。 

※モデリングした構造は通常この後 【4. 分子構造の調整と最適化】 に進みますが、今回は次の分子構築を始めるので、

Clear Scene アイコン（  ）または[File > New] をクリックして画面を初期化し、次の分子の構築に進んでください。 
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【Tips】カルボン酸のプロトン化状態 

カルボキシ基を構築すると、デフォルトでは-C(=O)-OH の状態になっています。[L]キーを押すと、Clean コマンドが実

行され、構造のクリーニング処理を行うことができますが、これを実行すると現在の pH（デフォルトでは pH: 7.4）に応

じてプロトン化状態や結合次数が調整されます。 

 

 

 

 

 

 

 

 

 

 

3.2 フロセミド（Furosemide） 

 次に、フロセミドを作成してみます。パーツは単純なので、アスピリンと同じように置換基を接続したり原子を置換した

りして順に組み立てていきます。今回は以下の手順で構築します。 

 

 

 

 

 

1. フェニル基を構築 

画面下の置換基の一覧から、「Unsaturated rings」カテゴリの

「Phenyl」をクリックします。 

 

 

[L]キー 
(Clean コマンド) 
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2. カルボキシ基を接続 

アスピリンの手順 2 と同様に、ベンゼン環の水素を 1 つマーク

し、置換基の一覧から「Oxygen」カテゴリの「Ester」の青い丸

●をクリックします。 

 

 

 

3. 水素 H を塩素 Cl に置換 

カルボン酸の反対側の水素をマークし、右クリックでコンテク

ストメニューを開き、Swap > Atom を選択します。 

 

                 

 

選択ダイアログから塩素（Chlorine）を選択し、OK をクリック

して H→Cl に置換します。 

 

 

【Point】 

キー操作で置換できる原子が割り当てられていない場合は、Swap メ

ニューから置換できます。 

 

4. スルホンアミドを接続 

先ほど構築したクロロ基（-Cl）の隣の水素をマークし、「Sulfur」

カテゴリの「Sulfonyl」をクリックします。 
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スルホニル基の水素がマークされた状態で、[N]キーを押して窒

素 N に置換します。 

 

 

 

 

5. 側鎖（エチル基）を伸長 

スルホンアミドの反対側の水素をマークし、「Carbon」カテゴ

リの「Ethyl」をクリックし、エチル基を接続します。 

 

 

 

6. フラン環を接続 

伸長した側鎖の末端水素をマークし、「Unsaturated rings」カテゴ

リの「Pyrryl」の赤い丸●をクリックします。 

 

 

 

 

ピロールの窒素 N をクリックしてマークし、[O]キーを押して酸

素 O に置換します。 

 

 

 

【Point】 

目的の置換基パーツが無い場合は、類似の置換基を代用して構築しま

す。（今回はフランが無いのでピロールで代用しました） 
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7. 側鎖の炭素を窒素に置換 

最後にベンゼン環に近い側鎖の炭素 C をマークし、[N]キーを押

して窒素 N に置換します。 

 

 

 

これでフロセミドの完成です。 

※モデリングした構造は通常この後 【4. 分子構造の調整と最適化】 に進みますが、今回は次の分子構築を始めるので、

Clear Scene アイコン（  ）または[File > New] をクリックして画面を初期化し、次の分子の構築に進んでください。 

 

 

3.3 ジアゼパム（Diazepam） 

 続いて、ジアゼパムを構築します。ジアゼパムは、ベンゼン環に 7 員環が結合したベンゾジアゼピン環の構築に少し工夫

が必要です。構築方法はいくつかありますが、今回は以下のように 7 員環から開始し、ベンゼン環を構築して作成してみま

す。 

 

 

 

 

 

1. 7 員環を構築 

画面下の置換基の一覧から、右端にある「Saturated rings」カテ

ゴリの「Cycloheptyl」をクリックします。 
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2. 7 員環と連結した 6 員環を構築 

Ctrl キーを押しながら隣り合う 2 つの水素をマークし、

「Carbon」カテゴリの「Butadienyl」をクリックし、6 員環を

形成します。 

 

 

【Point】 

▪ 置換基パーツを利用して直接ベンゼン環を繋げることができな

いので、ブタジエニル基を利用して一旦 6 員環を形成しまし

た。 

▪ 複数の原子をマークすると、複数の接続点で一度に接続できま

す。 

 

3. 結合次数を調整 

7 員環と 6 員環を接続している 2 つの炭素原子をマークし、キ

ーボードの[2]キーを押し、二重結合 (黄色) に調整します。

 

【Point】 

▪ 数字キーを使って結合次数を簡単に変更できます。 

▪ 原子を 2 つマークした後、右クリックのメニューから Add > to 

soup: Bond を選択し、結合次数を調整することもできます。 

 

7 員環側にも 2 重結合があるので、ベンゼン環の隣の炭素を続

けて 2 つマークし、上記と同様に[2]キーを押して結合次数を調

整しておきます。 

 

 

 

 

4. 水素 H を塩素 Cl に置換 

フロセミドの構築手順 3 と同じように、ベンゼン環の水素 H を

塩素 Cl に置換します。（マークした水素を右クリックし Swap 

> Atom を選択、選択ダイアログから塩素（Chlorine）を指定） 
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5. 炭素 C を窒素 N に置換 

炭素をマークし[N]キーを押して、窒素 N に置換します。操作

を繰り返し、7 員環の 2 か所の炭素 C を窒素 N に変換します。 

 

 

 

 

6. 水素 H をメチル基 CH3に変換 

窒素に結合した水素をマークし、[C]キーを押してメチル基に

変換します。 

 

 

 

7. 水素 H をカルボニル（＝O）に変換 

N-CH3の隣の水素をマークし、置換基の一覧から、「Oxygen」

カテゴリの「Oxo」をクリックします。 

もう一方の水素が残ったままになっているので、マークして

Delete キーを押して削除しておきます。 

 

 

8. フェニル基を接続 

ベンゼン環の隣の水素をマークし、置換基の一覧から、

「Unsaturated rings」カテゴリの「Phenyl」をクリックします。 

 

 

これで、ジアゼパムの完成です。 

※モデリングした構造は通常この後 【4. 分子構造の調整と最適化】に進みますが、今回は次の分子構築を始めるので、

Clear Scene アイコン（  ）または[File > New] をクリックして画面を初期化し、次の分子の構築に進んでください。 

削除(Delete) 
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【Note】結合次数の調整 

 先ほど構築したジアゼパムは、ケクレ構造（単結合/二重結合）と共鳴構造のベンゼン環が混在しています。気になる場

合は、後述のエネルギー最小化計算を実行後、Clean 処理（Edit > Clean > All）又は TypeBond コマンド（Edit > Adjust bond 

orders > Type bond）を実行して結合次数の再割り当てを行うことで、共鳴構造に統一できます。結合次数の調整について

の詳細は、補足の 【5.1 結合次数の変更・調整】 をご覧ください。 

 

 

3.4 チオトロピウム（Tiotropium） 

最後に、チオトロピウムを構築します。チオトロピウムは 7 員環の架橋形成がポイントです。以下の流れで構築していき

ます。 

（※以下のスクリーンショットは棒球モデルのサイズを調整（View > Style atoms > Parameters）して表示しています。） 

 

1. 7 員環を構築 

画面下の置換基の一覧から、一番右端の「Saturated rings」カテ

ゴリの「Cycloheptyl」をクリックします。 

 

 

 

 

 

   

 

 

 

※手順 1 の構造を回転させて表示しています。 

2. 7 員環に窒素架橋を形成 

3 つ隣の炭素に結合した水素と近接した 2 つの水素を探し、

Ctrl キーを押しながら 2 原子をマークして、[N]キーを押して窒

素架橋を形成します。 

 

【Point】 

2 つの原子をマークし、原子が割り当てられたキーを押すと架橋を

形成します。 
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3. アミンの水素をメチル基に置換 

手順 2 で作成した窒素に結合している水素をマークし、[C]キ

ーを押して炭素（メチル基）に置換します。（操作を繰り返し

て 2 か所の水素を置換します。） 

 

 

4. 酸素架橋を構築 

新たに形成された 5 員環側の、隣接する上向きの 2 つの水素を

マークし、[O]キーを押して架橋を形成します。 

 

 

 

5. エステルを接続 

酸素架橋の反対側にある下向きの水素をマークします。 

 

 

 

置換基の一覧から「Oxygen」カテゴリの「Ester」の赤い丸●

をクリックし、エステルを接続します。 
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6. 末端の水素をメチル基に置換 

エステルの末端の水素をマークし、[C]キーを押してメチル基

に置換します。 

 

 

7. メチル基の水素を酸素（-OH）に置換 

前の手順で作成したメチル基の水素の一つをマークし、[O]キ

ーを押して酸素（-OH）に置換します。 

 

 

8. チオフェン環の構築 

メチル基の残りの水素を 1 つマークし、「Unsaturated rings」カ

テゴリの「Pyrryl」の赤い丸●をクリックします。 

Alt キーを押しながらもう一方の水素をクリックし、こちらに

もピロールを接続します。 
 

【Point】  

Alt キーを押しながら原子をクリックすると、前と同じ操作を繰り返

すことができます。 

 

前の手順で作成したピロールの窒素をマークして、[S]キーを押

して硫黄 S に置換します。もう一方のピロールも同様に操作

し、チオフェン環を構築します。 

 

これで、チオトロピウムの完成です。 
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4. 分子構造の調整と最適化 

 手動で構築した分子モデルは、結合角や結合距離が必ずしも適正とは限りません。そのため、必要に応じて結合長・結合

角・二面角などのジオメトリを確認・修正した上で、分子力場によるエネルギー最小化や、MOPAC（半経験的分子軌道法）

による構造最適化を行い、構造を適正化してください。 

初期構造に無理な歪み（極端な結合長、原子同士の衝突、過度なねじれ等）があり、通常の Clean 処理で修正できない場

合は、まずエネルギー最小化によって構造を安定させた後、ジオメトリを微調整すると目的の形を得やすくなります。一方、

初期構造が完成形に近い場合は、直接 MOPAC で最適化することも可能です。また、エネルギー最小化で大まかに整えてか

ら MOPAC で精密化するといった段階的なアプローチも有効です。 

なお、YASARA の標準機能では配座探索（自動生成）は行えません。エネルギー最小化は「初期構造から最も近い安定

点」へ収束させる手法であるため、必ずしもグローバルな最安定構造が得られるとは限らない点に注意が必要です。特定の

立体構造を再現したい場合は、あらかじめジオメトリを調整して適切な初期構造を作成してから、最適化を実行してくださ

い。 

 

4.1 ジオメトリ情報の確認・変更方法 

構造最適化の前に、各種ジオメトリの確認・調整方法を紹介します。この操作は必須ではありませんが、立体異性体のモ

デリングなどで特定の構造を再現したい場合は、この段階で結合距離や結合角を適切に設定し、初期座標を調整しておく必

要があります。エネルギー最小化や MOPAC による構造最適化では局所最適化が行われるため、必ずしも差異安定構造に収

束するわけではありません。初期座標が適切でないと、意図しない構造へと収束する可能性もあるため、事前にジオメトリ

を調整するなどして、目的とする立体構造を構築してください。 

 

4.1.1 結合長／結合角／二面角の確認 

 原子間の各ジオメトリ情報は、操作画面の左側に表示されるヘッドアップディスプレイ（HUD）から確認することができ

ます。Ctrl キーを押しながら複数の原子をクリックしてマークすると、左下に各情報が出力されます。 

 

マークされた原子数 HUD に表示される情報 

1 原子・座標（速度）・結合情報など 

2 上記に加えて、結合長（距離） 

3 上記に加えて、結合角（角度） 

4 上記に加えて、二面角 

 

 

 

また、次に紹介する「Distance」「Angle」「Dihedral」コマンドを使用して情報を出力することもできます。 

コマンド実行例（28,27,6,20 番の原子の二面角を出力する）： 

> Dihedral 28,27,6,20 

> Dihedral 28  O   UNK    1  A - 27  C9  UNK    1  A -  6  C10 UNK    1  A - 20  C15 UNK    1  A:  119.872 

距離 

角度 

二面角 

出力値 
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4.1.2 結合長／結合角／二面角の変更 

 原子間の結合長／結合角／二面角は、それぞれ Distance / Angle / Dihedral コマンドを利用して確認や変更ができます。 

操作画面でこれらのコマンドを利用してジオメトリを変更するには、次の 2 つの方法があります。構造を確認しながら手動

で調整したい場合は【① 操作画面から実行する方法】、特定の値を指定して調整したい場合は後者【② メニューから実行

する方法】を利用するとよいです。 

先ほど構築したチオトロピウムの構造を使って、各種操作を試してみてください。 

 

 

各コマンドのイメージ 

 

① 操作画面から実行する方法 

変更したい箇所の原子を、Ctrl キーを押しながらクリックして複数マークし、1 つ目にマークした原子（白いハイラ

イトで表示）を右クリックしてコンテクストメニューを開きます。 

  

 [Geometry] メニューから各種（赤枠部分）選択すると、調整バーが表示されるので、これを操作してジオメトリを

調整します。 

 

▪ [Distance/Angle/Dihedral] を選択 

これらを選択すると、「Bound=No」でコマンドが実行され、直接結合した原子間の、特定の 1 か所のジオメト

リを調整できます。直接結合している 2 原子をマークすると [Distance]、3 原子をマークすると [Angle]、4 原子

をマークすると [Dihedral] を調整できます。 

「Bound」オプション： 

有効な場合は、直接結合している原子のみが

考慮される。 

Bond=No 

Bond=Yes 
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▪  [Bond Distance/Angle/Dihedral] を選択 

これらを選択すると、「Bound=Yes」でコマンドが実行されます。この場合はマークした原子が直接結合してい

なくてもよく、マークした原子の選択によっては複数個所のジオメトリを一度に操作できます。例えば、4 つの

結合をはさんだ 2 原子をマークして [Bond Distance] を選択した場合、2 原子間にある各結合距離をそれぞれ調

整できます。 

 

（マークした原子間で操作できる箇所が複数あれば、それぞれのバーを動かして各ジオメトリを調整できる。） 

 

② メニューから実行する方法 

メニューから[Edit > Geometry > Distance/Angle/Dihedral] を選択します。原子の選択ダイアログが表示されるので、

順に対象の原子を選んでいきます。続く画面で変更したい値を入力し、[Consider only bound atoms] で「Bound」オプ

ションを設定（デフォルトでは Bound=No）して[OK] を押して実行します。  

 

 
 

 

【Tips】ジオメトリ調整エラーについて 

環構造に含まれる原子間の長さや角度などのジオメトリを変更しようとするとエラーとなります。閉じた環のジオメト

リを変更したい場合は、一度結合を削除して環を開いてから調整する必要があります。  

結合を削除：結合の両端の原子をマークし、一つ目にマークした原子上で右クリック、[Delete > Bond] を選択します。 

結合を形成：上記と同様の操作でコンテクストメニューを開き、[Add > to soup: Bond] を選択します。 

  

Bound オプション設定 

チェックを入れると Bond=Yes 
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4.1.3 シミュレーションを利用した構造調整 

 前述のコマンドを利用した調整方法では、環構造の立体を大きく変えたい場合（例えば、シクロヘキサンの Chair 型/Boat

型の変換など）など、結合の削除や再結合などの操作が必要となり、操作が難しいことがあります。より感覚的に立体構造

を調整するには、シミュレーションを利用し、原子をマウス操作で直接動かす方法もあります。先ほどのチオトロピウムの

構造を使って、操作を試してみてください。 

 

1. [ I ] キーを押して HUD を表示し、Ctrl + [ I ] キーを押して「SIMULATION PARAMETERS」画面を表示します。 

 

 

2. F10 キーを押して TempCtrl を切り替え、[Steepest descent]（最急降下法）に設定し、F12 キーを押してシミュレーショ

ンを開始します。 

 

3. 動かしたい原子をクリックしてマークし、Ctrl + 右クリックしてドラッグします。この操作により、マークしている

原子をマウスポインタの方向へ引き寄せることができます。 

 

4. 作業が終了したら、再度 F12 キーを押してシミュレーションを停止します。 
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【Tips】FixAtom で原子を固定する 

動かしたくない原子が連動してしまう場合は、FixAtom コマンドを利用して原子を固定します。原子をマークして右クリ

ックし、[Fix > Atom] を選択します（固定した原子は黄色で表示されます）。解除する場合は [Free > Atom] を選択します。 

 

 

4.2 エネルギー最小化計算 

 最後に、構築した分子のジオメトリ最適化を行います。低分子ビルディングモードで構築したモデルは、原子が衝突して

いたり、結合長が適切でなかったりするなど、物理的に無理な構造を含む場合があるので、エネルギー最小化計算を行い、

構造を整えます。すでにある程度整った構造であれば、エネルギー最小化計算を行わずに次の MOPAC による構造最適化を

行うこともできます。 

YASARA でエネルギー最小化計算を行うには、以下の方法があります。 

 

① Experiment メニューから Energy minimization を実行 

② 付属マクロファイル（em_run.mcr/ em_runclean.mcr）を実行 

③ インタラクティブな操作でエネルギー最小化シミュレーションを実行 

 

通常、この中から目的に適した手法を選択・実行しますが、ここでは、簡単に実行できる①の Experiment を利用する方法

を紹介します。②の実行方法について知りたい方は弊社ウェブサイトで公開しているエネルギー最小化チュートリアル

（https://www.affinity-science.com/yasara-tech/）を、③の操作方法について知りたい方は、YASARA ヘルプムービー（Help > 

Play Help movie）の【3.2. Interactive simulations for modeling】 や 【3.3. Accurate simulations in water】 をご参照くださ

い。 

 

【Note】マクロファイル em_runclean.mcr 実行時の注意点 

エネルギー最小化用マクロファイル em_runclean.mcr を実行すると、はじめに Clean 処理が行われます。エネルギー最小化

前に結合次数の再割り当てが行われるため、間違った割り当てがされていないか注意してください。Clean 処理を行わない

em_run.mcr を実行して構造最適化を行った後に、Clean 処理（Edit > Clean > All）を行う方が正確に結合次数の割り当てがで

きます。 

 

 

❑ Experiment Energy minimization の実行方法 

1. メニューから[Options > Choose experiment > Energy minimization] をクリックして実行します。 

自動でシミュレーションセルが作成され、エネルギー最小化計算が行われます。 

 

https://www.affinity-science.com/yasara-tech/
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終了すると、操作画面にエネルギー最小化後の構造が表示され、コンソール画面に最終的なエネルギー値が出

力されます。 

 

 

2. 構造ファイルの保存：メニューから[File > Save/Save as] を選択し、作成した化合物の構造を保存します。 

保存せずにこのまま次の MOPAC による構造最適化を行ってもよいです。 

 

4.3 MOPAC(YAPAC)による構造最適化 

 YASARA では、MOPAC の派生版である YAPAC を利用した半経験的量子化学計算が可能です。半経験的量子化学計算を

利用した構造最適化は、次の手順で行います。 

 

❑ MOPAC(YAPAC)による構造最適化の実行方法 

1. QM 計算手法の設定：メニューから [Options > Quantum mechanics > AM1(Austin Model 1)] を選択します。 

MNDO、AM1、PM3 を選択できますが、構造最適化を行う場合は AM1 が適しているのでこちらを指定します。

（各手法の詳細は、YASARA ユーザーマニュアルの QuantumMechanics コマンドページをご覧ください。） 

 

2. 構造最適化の実行：メニューから  [Edit > Optimize > All] を選択し、一番上の  [Semi-empirical Quantum 

mechanics (MOPAC)] にチェックを入れて構造最適化を実行します。 

 

 

計算が終了すると、操作画面に構造最適化された構造が表示され、コンソール画面には生成エネルギー値が出

力されます。 

 

 

3. 構造ファイルの保存：メニューから[File > Save/Save as] を選択し、作成した化合物の構造ファイルを保存しま

す。 

 

【Tips】YAPAC とは 

YAPAC は、James P. Stewart によって開発された MOPAC を基に派生した、半経験的量子化学計算を行うための特殊モジ

ュールです。YASARA では、この YAPAC を利用して半経験的量子化学計算を実行できます。利用可能な手法として 

MNDO（Modified Neglect of Diatomic Overlap）、AM1（Austin Model 1）、PM3（Parametric Method 3） があり、これらを用

いて分子の構造最適化や生成エネルギーの計算が行えます。 
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5. 参考情報 

5.1 結合次数の変更・調整 

 構築したモデルの結合次数を調整したい場合、Clean コマンドや TypeBond コマンドを利用して自動の結合次数の再割り

当てを行うか、AddBond コマンドや SwapBond コマンド等を利用して手動で調整する方法があります。歪んだ構造を持つ場

合、前者の方法だと自動の結合次数の割り当てに失敗する可能性があるので注意してください。そのような場合は AddBond

コマンドを利用して手動で調整します。 

結合次数を変更したら、エネルギー最小化計算を行って構造の最適化を行います。共鳴系の割り当ては、さらにその後に

Clean コマンドや TypeBond コマンドを行うとうまく調整できることが多いです。例えば、実践操作で構築したジアゼパム

のように、ベンゼン環の結合次数が共鳴の 1.5 結合と共役（単結合と二重結合）が混在している場合は、エネルギー最小化

計算を実行した後に Clean コマンドを実行すると、共鳴の 1.5 結合に統一できます。（エネルギー最小化前に手動で結合次

数を調整したり、ResonateBond コマンドを利用してベンゼン環の結合次数を 1.5 に調整したりしておいてもよいです。） 

 

関連するコマンドは以下になります。詳細を知りたい方は、YASARA ユーザーマニュアルの各コマンドページをご参照

ください。 

関連コマンド：TypeBond, Clean, AddBond, SwapBond, DellBond, KekulizeBond, ResonateBond 

 

ここでは、GUI 操作での結合次数の調整方法を紹介します。 

 

❑ 特定の結合の結合次数を変更したい場合 

関連コマンド： 

AddBond（原子間に結合を追加するコマンド。既に結合が存在する場合は新しい結合に置き換えられる。） 

SwapBond（原子間の結合の結合次数を変更するコマンド。） 

 

操作方法がいくつかあるのでそれぞれ紹介しますが、実行される処理は同じです。  

 

▪ 方法 1（AddBond コマンド） 

分子ビルディングモード（  ）で結合の両端の原子を Ctrl キーを押しながら複数マークし、対応する数字キー

を押します。最も簡便な方法です。水素は結合次数に合わせて自動で調整されます。  

1 キー：単結合 2 キー：二重結合 3 キー：三重結合： 4 キー：四重結合 5 キー：1.5 結合（共鳴） 

 

▪ 方法 2（SwapBond コマンド） 

結合の両端の原子を Ctrl キーを押しながら複数マークし、最初にマークした原子（白いハイライトで表示）上で

右クリックしてコンテクストメニューを開きます。 

メニューから [Swap > Bond] を選択し、表示されるダイアログで変更したい結合を選択します。下にある「Update 

surrounding hydrogen atoms」（Update オプション）にチェックを入れると変更した結合次数に合わせて自動で水素

が付加/削除されます。 
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▪ その他の操作方法 

メニューの[Edit > Adjust bond orders > Swap bond] または [Edit > Swap > Bond] からも結合次数を変更できま

す。 

 

 

【Tips】AddBond コマンドをメニューから実行 

右クリックで表示されるコンテクストメニューから[Add > to soup: Bond] を選択しても同様の処理が行われます。この

場合は、結合が無い原子間に新たに結合を追加することもできます。ダイアログの「Add only bonds shorter than~」は AddBond

コマンドの「LenMax」オプションに相当し、最大結合長を設定できます（0 の場合は全ての結合が追加）。 

 

 

 

 

❑ 結合次数を自動調整したい場合（コマンド：TypeBond, Clean） 

関連コマンド： 

TypeBond（現在の pH を考慮して原子間の結合次数を再割り当てするコマンド。） 

Clean（シミュレーション用に構造をクリーニングするコマンド。処理の中に TypeBond が含まれる。） 

 

▪ 方法 1（TypeBond コマンド） 

メニューから [Edit > Adjust bond orders > Type bond,~] を選択します。水素が欠損している可能性があれば[Type 

bond, hydrogens may be missing] 、全ての水素が付加している場合は[Type bond, all hydrogens are present]を選

択します。（この選択は TypeBond コマンドの HydMissing オプションに相当します。） 

  

原子の選択ダイアログが表示されるので、調整したい結合を結ぶ原子を選択します。構造全体を調整したい場合

は、右側の [Belongs to or has] リストから [All] を 2 回選択して下さい。 

 

▪ 方法 2：（Clean コマンド） 

メニューから[Edit > Clean > All/Object] を選択します。または、低分子ビルディングモードで[L]キーを押して

も Clean 処理を実行できます。 

 

❑ 共鳴結合（分数の結合）を単結合と二重結合に置き換えたい場合（コマンド：KekulizeBond） 

KekulizeBond コマンドを実行すると、共鳴結合を単結合と二重結合に置き換えることができます。例えば、全ての結

合が結合次数 1.5 で表現されたベンゼン環は共役単結合/二重結合に変更されます。 

▪ メニューから [Edit > Adjust bond orders > Kekulize bond] を選択して実行します。 
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❑ 共役単結合/二重結合を共鳴結合に置き換えたい場合（コマンド：ResonateBond） 

KekulizeBond コマンドで行われた変更を元の共鳴構造に戻すことができます。例えば、共役単結合/二重結合で表現さ

れたベンゼン環は全て結合次数 1.5 の結合に変更されます。 

▪ メニューから [Edit > Adjust bond orders > Resonate bond] を選択して実行します。 

 

 

【Tips】投げ縄ツールを使って結合方式を変更する 

画面上部にある投げ縄アイコン（   ）を利用して分子を選択し、右クリックでコンテクストメニューを開くと、ここ

からも [Adjust bond orders] メニューを選択・実行できます。この場合、より直感的に適用範囲を指定可能です。  

 

 

5.2 不斉中心(S/R)の変更方法 

 不斉中心の立体(S/R)を変換したい場合、SwapPosAtom コマンドを利用するのが便利です。不斉炭素に結合する原子を 2

つマークし、はじめに選択した原子上で右クリック、コンテクストメニューを開き、[Swap > Atom positions]を選択します。 

 

 

5.3 分子構築に関するヘルプムービー 

 YASARA には、ヘルプムービーというインタラクティブなチュートリアルが付属しています（Help > Play help movie）。

低分子の構築に関連する項目は以下になります。 

 

・低分子ビルディングモードの操作について 4.1. Building small molecules 

・分子の QM 最適化などを含む内容     3.4. Simulation and quantum mechanics of small molecules 

 

 

5.4 その他の参考資料 

 弊社ウェブサイトでは、エネルギー最小化計算をはじめとする各種チュートリアルを公開しています。その他技術情報に

ついては、ブログ記事や FAQ もあわせてご参照ください。 

 

YASARA 日本語チュートリアル 

https://www.affinity-science.com/yasara-tutorial 

  

Affinity Science Blog/.org 

https://www.affinity-science.org/ 

 

YASARA よくある質問 

https://www.affinity-science.com/yasara-faq/ 

L-システイン D-システイン 

SwapPosAtom 
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