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概要：YASARA Structure (Version 25.12.1) による、SMD(Steered Molecular Dynamics)シミュレーションの実行と解析
方法についてチュートリアル形式で説明します。 

1. はじめに  

1.1 SMD (Steered Molecular Dynamics) シミュレーションとは 

 SMD (Steered Molecular Dynamics) シミュレーションは、特定の原子や分子に対して意図的に外力を加える手法です。こ

れにより、通常の MD 法では観測が困難な時間スケールで起こる現象（例：リガンドの脱離、タンパク質の変性など）を強

制的に引き起こし、その動的プロセスを詳細に解析することが可能になります。  

 YASARA では、ソフト付属のマクロファイルを使用することで、これらのシミュレーションと解析を容易に実行するこ

とができます。 

 

YASARA による SMD シミュレーションの基本概念 

 

1.2 YASARA における実行手順 

 YASARA で SMD を実行する際は、付属のマクロファイル md_runsteered.mcr を使用します。基本的な前処理や実行、

解析方法は通常の MD シミュレーションと同様ですが、SMD 特有の要素として、原子や分子を引っ張る際の方向（牽引方

向、ベクトル）の設定があります。この牽引方向はマクロによって自動設定させることも、ユーザーが任意に指定すること

も可能であり、矢印オブジェクトの使用の有無により次の 2 通りのアプローチがあります。 

 

❑ 方法 A：矢印オブジェクトを設定しない場合（デフォルトの動作） 

自身で指定せず、デフォルトで実行する場合は「タンパク質の中心からリガンドの中心に向かうベクトル」がマク

ロ内の処理により自動的に設定されます。付属のマクロファイルを編集せずにそのまま実行することができ、タンパ

ク質の表面や浅いポケットにリガンドが結合しているような場合に適しています。（マクロファイルを編集すること

で、ベクトルの向きを指定することもできます。） 
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❑ 方法 B：矢印オブジェクトを設定する場合（ユーザー指定の動作） 

構造上に矢印（Arrow）オブジェクトを配置し、任意の牽引方向を指定します。矢印オブジェクトに基づいてベクト

ルが設定され、ベクトルの方向に向かってリガンド全体の原子を引っ張ります。タンパク質の深いトンネル内にリガ

ンドがある場合や、方法 A では適切な脱出経路が確保できない場合、あるいは任意の方向を視覚的に指定したい場合

などに向いています。 

 

選択する方法によって対応するファイル形式や必要な前処理が異なります。後述の【2.2 構造ファイルの準備方法】 セ

クションにて、方法 A・B それぞれの場合の手順を記載していますので、目的に合わせて参照してください。 

 

シミュレーション終了後は、通常の MD シミュレーションと同様に、md_play.mcr マクロによるトラジェクトリの再生や

動画の出力、md_analyze.mcr によるトラジェクトリ解析といった多くの MD 解析用マクロが適用可能です。 

 

1.3 本チュートリアルの内容 

 本チュートリアルでは、HIV プロテアーゼとリトナビルの共結晶構造（PDB ID: 1HXW）を使用し、リトナビルを結合ポ

ケットから引き抜くシミュレーションを実行し、解析マクロを実行して結果を確認します。 

 

 

2. 準備 

 マクロファイル実行前に必要な操作を行います。 

 

【Tips】ハードウェア性能の確認 

 シミュレーションを実行するにあたり、使用マシンの計算速度を知りたい場合、メニューから [ Option > Macro & Movie 

> Play macro > md_runbenchmark.mcr ] を実行してハードウェア性能を確認することができます。詳細については、別チ

ュートリアル「分子動力学計算」をご参照ください。（https://www.affinity-science.com/yasara-tutorial/） 

 

 

2.1 共通の前処理 

2.1.1 作業フォルダ（ディレクトリ）の作成 

 デスクトップ等に、入出力データを格納する任意の作業フォルダ（ディレクトリ）を作成します（Windows ではエクスプ

ローラ、Linux では mkdir コマンド等を使用）。作成場所やファイル名は任意ですが、YASARA 上で表示が乱れるため、日

本語を含まない方が好ましいです。 

 

例 

(Windows) C:¥Users¥username¥Desktop¥YASARA_DATA¥tuto_smd 

(Linux)   /home/username/YASARA_DATA/tuto_smd 

 

任意で操作画面のメニューから [ Options > Working directory ] を選択し、作成したディレクトリを指定し作業ディレク

トリを設定してください。（ここで設定したディレクトリはカレントディレクトリとなります。） 

 

2.1.2 PDB ダウンロードと構造可視化・確認 

メニューから[ File > Load > PDB file from Internet ] を選択し、「1hxw」と入力、[OK]ボタンをクリックして PDB ファイ

ルをダウンロードして読み込みます。（読み込み時のオプションはデフォルトで問題ありませんが、必要に応じて任意に設

定してください） 

https://www.affinity-science.com/yasara-tutorial/
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続いて、画面右上に表示されている「SCENE CONTENT」上で、オブジェクト名「1hxw」をクリックし、読み込まれたオ

ブジェクトを確認します。Vis 列をクリックして表示・非表示を切り替えてみると、上から順に「タンパク質（A 鎖・B 鎖）」、

「リガンド（リトナビル）」、そして「水分子（赤字）」で構成されていることが確認できます。 

 

 

2.1.3 不要分子の削除 

 今回読み込んだ構造では、不要な分子が水分子のみ含まれているため、メニューから [ Edit > Delete > Waters ] を選択し

て水分子をまとめて削除しておきます。 
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水分子以外の不要分子が含まれている場合は、メニューから [ Edit > Delete > Molecule ] を選択するなどし、計算に不要

な分子などを取り除いてください。（画面右上の「SCENE CONTENT」上で Molecule を個別に右クリックし、「Delete」を実

行して不要分子を削除することもできます。） 

 

 

前処理後の構造 

 

本チュートリアルでは、これ以降、タンパク質である HIV プロテアーゼを「レセプター」、リトナビルを「リガンド」

として扱います。（SMD 用の付属マクロでは、デフォルトではタンパク質を自動認識してレセプターとして扱います。） 

 

 

2.2 構造ファイルの準備 

ここからは、牽引方向の設定方法により構造ファイルの準備手順が異なります。【1.2 YASARA における実行手順】に記

載した各方法の特徴を参考に、いずれかを選択して該当するセクションへ進んでください。 

 

❑ 【2.2.1 方法 A：矢印オブジェクトを設定しない場合（デフォルトの動作）】 

❑ 【2.2.2 方法 B：矢印オブジェクトを設定する場合（ユーザー指定の動作）】 

 

 最も簡便にシミュレーションを開始できるのは、方法 A で矢印オブジェクトを使用せず、デフォルト設定のマクロを実

行する方法です。手軽に実行したい方や、まずは標準的な条件で試してみたい方は、こちらの方法をお試し下さい。 

 

 

2.2.1 方法 A：矢印オブジェクトを設定しない場合（デフォルトの動作） 

 この場合、基本的には先ほどの前処理を終えた構造を .pdb または .yob 形式で保存するだけで準備が完了します。 

（.sce 形式も使用できますが、追加の前処理が必要です（後述の【Note】参照）。） 

 

1. 構造ファイルの保存（.pdb、.yob） 

まず、前処理を行った構造を.pdb または.yob 形式で保存します。どちらで保存しても構いませんが、ここでは.pdb

形式ファイルで保存しておきます。  
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メニューから [ File > Save as > PDB file ] を選択し、Sequence リストまたは Name リストから「1hxw」オブジェク

トをクリックして[OK]、続くダイアログ画面で先ほど作成した作業フォルダを選択し、任意のファイル名を入力して

保存します。（例：1hxw.pdb） 

 

 

 

 

【Note】.sce 形式ファイルを使用する場合 

.sce 形式で構造ファイルを用意したい場合は、これまでの前処理に加えて、Clean 処理、水素結合ネットワークの最適化、

シミュレーションセルの設定が必要となります。操作方法については、次項【2.2.2 方法 B：矢印オブジェクトを設定する

場合（ユーザー指定の動作）】の手順 3 以降の操作をご参照ください。 

 

 

2. マクロファイルの編集（任意） 

 SMD 用の付属マクロファイル「md_runsteered.mcr」では、必要に応じて内部のパラメータや牽引方向を設定することがで

きます。デフォルトの設定では、レセプターの重心からリガンドの重心へ向かう方向に牽引ベクトルが自動で定義されま

す。この標準的な設定でシミュレーションを行う場合はマクロを編集する必要はありませんので、そのまま次の操作【3. シ

ミュレーション実行】へ進んでください。 

 

パラメータをカスタマイズしたい場合は、マクロファイル内の変数を書き換えた上で作業フォルダ等に保存して使用し

ます。設定可能な項目の詳細や編集方法については後述の参考情報の【5.2 マクロのパラメータ設定について】に記載して

いますのでご参照ください。準備ができたら【3. シミュレーション実行】へ進んでください。 

 

【Tips】レセプターとリガンドの自動認識について 

本マクロには、牽引方向の基準となるレセプター（receptorsel）とリガンド（ligandsel）を指定する変数が含まれています。

通常これらは自動で認識されるため、通常は付属の「md_runsteered.mcr」マクロを編集せずにそのまま実行することができ

ます。ただし、リガンドが自動認識されない場合や、レセプターやリガンドを自身で指定したい場合は編集して直接指定し

てください。 
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2.2.2 方法 B：矢印オブジェクトを設定する場合（ユーザー指定の動作） 

この方法では、構造ファイルに「矢印（Arrow）オブジェクト」を含める必要があります。矢印オブジェクトの情報を保

存できるのは YASARA Scene 形式（.sce）であるため、最終的にこの形式で構造ファイルを保存します 。.sce 形式の場合、

通常の MD シミュレーションと同様に「構造のクリーニング」「水素結合ネットワークの最適化」「シミュレーションセルの

設定」をユーザー自身で事前に行う必要があります 。以下の手順に従って準備を進めてください。 

 

1. 矢印オブジェクトを表示 

 まず、メニューの [ Effects > Show arrow > between points ] をクリックします。設定ダイアログが表示されますが、

ここではデフォルトのままでよいので [OK] をクリックして下さい。 

（※設定ダイアログでは、XYZ 座標に基づいて矢印の位置や方向を直接指定することもできます。） 

 

2. 矢印オブジェクトの移動と牽引方向の設定 

 続いて、表示された矢印オブジェクトを移動して、目的の牽引方向に配置します。操作対象オブジェクトは、Shift

キーを押して切り替えることができます（現在の操作対象オブジェクトは画面右下に表示されます）。 Obj 2（矢印）

と Obj All（全体）を Shift キーで切り替えながら、矢印を目的の牽引方向に配置してください。 

 

 

ここでは、結合ポケットの出口に向かうような方向に指定してみます。 

 

矢印オブジェクトの配置例 

 

なお、デフォルトのマクロの設定では、リガンド分子全体を矢印の方向に牽引する設定になっています。（リガン

ドは通常マクロ内で自動認識されます。マクロファイルを編集することで引っ張る対象を変更することもできま

す。） 
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【Tips】結合ポケットの表面を表示する 

 牽引方向を決める際、結合ポケットを確認しやすくするためには、タンパク質の表面を表示することをおすすめします 。

メニューから [ View > Show surface > of: Molecule ] を選択し、続く選択ダイアログで右側にある「Belongs to or has」リス

トから「Protein」を選択し[OK]をクリックします。続いて、表面の設定ダイアログが表示されるので、必要に応じて設定し、

[OK]を押します（デフォルト設定でも問題ありません）。すると、タンパク質の表面が表示されます。 

表面を非表示に戻したい場合は、メニューから [ View > Hide surface of > All ] を選択して下さい。 

 

表示例：貫通するポケットが確認できる 

 

 

 

3. クリーニング処理 

 続いて、構造のクリーニング処理を行います。 

① メニューから [ Edit > Clean > All ] を選択し、クリーニング処理を行います。 

② メニューから [ Edit > Add > hydrogens to: Object & optimize ] を選択して、選択ダイアログで「1hxw」をダブル

クリックし、水素結合ネットワークの最適化を行います。 

 

4. シミュレーションセル（SimCell）の設定 

 次に、計算空間となるシミュレーションセルを設定します。メニューから [ Simulation > Define simulation cell ] を

選択します。続く設定ダイアログで、セルの設定を行います。 

ここでは例として、Shape: Cuboid（直方体）、Extend: 18 Å に設定し、「around all atoms.」をクリックして設定します。 

  



8 

 

 

シミュレーションセルの設定例 

 

【Note】シミュレーションセルの設定について 

シミュレーションセルの形状は「Cube」または「Cuboid」を使用してください。セルサイズに厳密な指定はありません

が、デフォルトのマクロでは「リガンドの移動距離が 15 Å に達した時点でシミュレーションを終了する（enddis パラメー

タ）」設定となっているため、リガンドがセルの境界を超えないよう、十分な空間を確保する必要があります。 

方法 A のように構造ファイルを .pdb または .yob 形式で用意する場合、シミュレーションセルが自動設定されますが、

この場合は周期境界越えを確実に防ぐための安全マージンとして、enddis 値の 2 倍である 30 Å が「Extend 値」として適用

されます。しかし、このデフォルト設定はセル全体が非常に大きくなり、充填される水分子の数が大幅に増えるため、計算

コストが高くなる傾向があります。 

計算効率を重視し、計算コストを抑えたい場合は、手動でより小さなセルを設定することをご検討ください。設定の目安

として、Extend 値を enddis パラメータ（デフォルト値 15 Å）に少し余裕を持たせた値（例：18 Å 程度）に設定すれば、多

くの場合問題なくシミュレーションを実行できます。もし、終了時にリガンドが周期境界を越える場合には、適宜 Extend 値

を大きく調整してください。 

なお、設定時に指定する「Extend 値」はセルの絶対的なサイズそのものではなく、「（選択した）原子からセルの境界まで

の最低距離」を指定するパラメータですので、混同しないようご注意ください。実際に作成されたセルのサイズを確認した

い場合は、Enter キーを押してコンソール画面を開き、「Cell」と入力して実行してください（メニューの Analyze > List > 

Cell properties からも同様の操作が可能です）。セルのサイズを含む各種プロパティ情報がコンソールに出力されます。 

 

 

5. 構造ファイルの保存 

 準備ができたら、構造ファイルを YASARA Scene 形式（.sce）で保存します。メニューから [ File > Save as > YASARA 

Scene ] を選択します。Browse から作業フォルダを開き、Filename に任意のファイル名を入力（例：1hxw.sce）して

[OK]をクリックしてください。 
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3. シミュレーション実行 

3.1 ターゲット設定 

マクロが処理を行う対象ファイルを設定します。メニューから [ Options > Macro & Movie > Set target ] を選択し、ダイ

アログ画面から先ほど保存した構造ファイルを指定し、Remove オプションは「file extension」にチェックを入れて [OK]を

クリックして下さい。 

 

3.2 マクロ実行 

 メニューから [ Options > Macro & Movie > Play macro ] を選択、Browse から「md_runsteered.mcr」を選択し[OK]をクリ

ックしてシミュレーションを実行します。 

 

事前にマクロファイルを編集することで、各種パラメータを変更することができます（参考情報【5.2 マクロのパラメー

タ設定について】を参照）。自身でパラメータを編集したマクロを実行する際は、編集済みのマクロファイルを Browse から

選択して実行してください。 

 

 

 

 

シミュレーション実行中の画面 
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エネルギー最小化などの前処理が終わり、SMD シミュレーションが開始すると、画面下方に現在のシミュレーション時

間（time）、リガンドの移動距離が最後に更新されたシミュレーション時間（last progress at ~）、リガンドの移動距離（distance）、

加速度（accel）、力（force）のパラメータ情報がリアルタイムで表示されます。 

（リガンドの移動距離（distance）の算出方法は、矢印オブジェクトの有無によりやや異なります。詳細については、補足の

【5.5 リガンドの移動距離（distance）の算出方法】をご参照ください。） 

 

また、シミュレーション中は牽引方向が赤い矢印で表示されます。このとき、矢印の始点が目的のリガンドに位置してい

るか確認してください。もし矢印がリガンドに接していない場合は、マクロがリガンドを誤って認識している可能性があり

ます。その場合は、マクロファイル内の「ligandsel」を編集してリガンドを手動で指定し、再度実行してください。マクロ

ファイルの編集方法やパラメータについては、【5.2 マクロのパラメータ設定について】をご参照ください。 

 

また、シミュレーション中に表示されるこの赤い矢印（牽引方向）は、タイムステップごとに再計算されます。矢印オブ

ジェクトを設定して牽引方向を指定した場合でも、牽引方向は空間的に固定されているわけではなく、レセプターの座標に

基づいて動的に更新されます。そのため、シミュレーションの進行に伴ってレセプターが移動や回転をしたとしても、牽引

方向はその座標変化に追従する仕組みとなっており、結果として計算中の赤い矢印が動いているように見えます。牽引方向

に関する詳細については、補足の【5.3 牽引方向の定義について】に記載しておりますので併せてご覧ください。 

 

 

【Tips】シミュレーションの再開方法 

マクロファイル（md_runsteered.mcr）の実行中に、システムトラブルによる強制終了や手動での中断が発生した場合でも、

シミュレーションを途中から再開することができます。再開の手順は初回実行時と同様で、同じマクロターゲットを指定し

た後に再度マクロファイルを実行してください。パラメータを編集したマクロを使用していた場合は、その編集済みのマク

ロを再度選択して実行するようにしてください。なお、マクロが既存のシミュレーションを継続するように設計されている

ため、再開する際に異なるパラメータを設定したマクロを選択・実行しても、一部のパラメータ（pH や NaCl 濃度など）が

反映されませんのでご注意ください。 
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4. 結果の確認 

 リガンドの移動距離（distance）が 15 Å（マクロの enddis パラメータで設定された値）に達すると、シミュレーションが

終了し、分子の動きが止まります。画面が静止したことを確認したら、出力された結果データの確認・解析に進みます。 

 

解析にあたっては、通常の MD シミュレーションと同様に各種 MD 解析用のマクロを実行することができます。本セク

ションでは、方法 A で実行した際の結果ファイルを例に挙げ、SMD 独自の出力ファイルの見方や、基本的な MD 解析マク

ロを使用した解析を紹介します。 

なお、YASARA のユーザーマニュアルでは、各スナップショットの結合エネルギーを算出するマクロ

「md_analyzebindenergy.mcr」の利用は、SMD ではあまり有用ではないと指摘されています。SMD はリガンドを強制的に引

き離す手法であるため、解析結果は単に結合エネルギーが 0 へと減少していく過程を示すに過ぎず、得られる知見が乏し

いためです。 

 

 

4.1 出力ファイルの確認 

 md_runsteered.mcr を実行すると、作業フォルダに以下のファイルが作成されます。このうち、上から 3 つのファイルが

SMD 独自の出力ファイルです。これらを開いて、計算結果を確認してみます。 

 

ファイル名 内容 

(MacroTarget)_acc.png 加速度とリガンドの移動距離を表したグラフ図 

(MacroTarget)_frc.png 力とリガンドの移動距離を表したグラフ図 

(MacroTarget).tab 牽引距離、シミュレーション時間、加速度、力のテーブル 

(MacroTarget).pka Experiment Neutralization の pKa 予測により作成されたファイル 

(MacroTarget).sce 開始時の溶質とシミュレーションセルを含む構造ファイル 

(MacroTarget)_water.sce 開始時の水を含めた全オブジェクトを含む構造ファイル 

(MacroTarget)00000.sim 

(MacroTarget)00001.sim  … 
シミュレーションのトラジェクトリファイル 

 

 

▪ (MacroTarget)_acc.png / (MacroTarget)_frc.png ファイル 

・(MacroTarget)_acc.png ファイルは、横軸にリガンドの移

動距離、縦軸に牽引加速度をとったグラフの画像ファイル

です。

・(MacroTarget)_frc.png ファイルは、横軸にリガンドの移動

距離、縦軸に力をとったグラフの画像ファイルです。 
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力と加速度の関係は、F = ma で定義されるため、リガンドの質量が一定である以上両者のグラフは同じ形状（相似形）

になります。また、グラフの上部には、「total work」として、総仕事量が出力されます。 

（リガンドの移動距離（Distance）の計算方法の詳細については、参考資料の【5.5 リガンドの移動距離（distance）の算出

方法】をご覧ください。） 

 

 これらのグラフからは、リガンドが結合ポケットを脱出する際に生じた抵抗を読み取ることができます。上図を例にとる

と、Distance（リガンドの移動距離）が 2 Å 付近に達するまで力（および加速度）が急激に増加していますが、これは水素

結合や疎水性相互作用といったリガンド・レセプター間の相互作用を断ち切る際、大きなエネルギー障壁を乗り越えている

過程を反映していると考えられます。 その後、値が安定している区間については、主要な相互作用から解放されたリガン

ドが、大きな抵抗を受けずに移動フェーズへ移行したことを示唆しています。  

 

 

【Note】グラフにピークが現れた場合 

 先ほどの例では比較的なだらかなプロファイルが得られていますが、場合によっては鋭いピークが現れる場合がありま

す（下図参照）。これは、リガンドが結合部位を脱出した後、別の場所に再びトラップされた可能性を意味します。この場

合は、まず後述の結果テーブル「(MacroTarget).tab」を開き、ピークが生じたシミュレーション時刻を確認します。次に、ト

ラジェクトリを可視化できる「md_play.mcr」マクロを実行し、該当する時刻の構造を観察してみてください。タンパク質の

構造変化を伴う動きであれば重要な知見となりますが、単に牽引方向に障害物があっただけで、別の方向なら自由に動けた

という場合は、解析上のアーティファクト（ノイズ）である可能性があります。 

 

ピークを観測した例 

 

 

▪ (MacroTarget).tab ファイル 

こちらは、リガンドの移動距離（Distance[A]）、シミュレーション時間（Time[ps]）、加速度（Acc[pm/ps^2]）、力（Force[pN]）

のデータがまとめられたファイルです。 
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4.2 トラジェクトリの可視化：md_play 

 続いて、トラジェクトリをプレイヤー形式で可視化するマクロ、「md_play.mcr」を実行し、シミュレーションの様子を確

認してみます。実行にはマクロターゲットの設定が必要です。シミュレーション後に YASARA を起動し直した場合などは

再度マクロターゲットを指定してください（【3.1 ターゲット設定】 を参照）。なお、シミュレーション終了後引き続き実行

する場合は、再設定の必要はありません。 

 

メニューから [ Options > Play macro ] を選択し、YASARA インストールディレクトリ> mcr 内に保存されている

「md_play.mcr」を選択して実行します。 

 

 

 

画面右側のボタンを操作し、スナップショットを進めたり戻したりすることができます。一番下にある[Superpose on start] 

を押すと構造の重ね合わせが、その隣の [Save MP4] を押すと動画の保存が可能です。動画には現在の表示画面が反映され

るため、事前にアングルや表示スタイルを調整したり、シミュレーションセルを非表示（Ctrl + I で Scene Content に切り

替え、Vis 列で表示を ON/OFF）にしたりして、見栄えを整えてから保存するとよいです。 

 なお、トラジェクトリの再生に使用しているトラジェクトリファイル（デフォルトでは.sim ファイル）には、原子の位置

と速度の情報のみ含まれるため、シミュレーション中に表示されていた牽引方向を示す矢印オブジェクトはここでは表示

されません。 

 

 

4.3 トラジェクトリの解析：md_analyze 

 次に、基本的な MD トラジェクトリ解析を行うマクロ「md_analyze.mcr」を実行します。実行方法は通常の MD シミュレ

ーションを実行した場合と同様です。こちらも、必要に応じて事前にマクロターゲットを設定しておいて下さい。 

※注意：前述の md_play から続けて実行する場合、メニューから [ Options > Macro & Movie > Stop ] を選択し、実行中の

マクロを停止してから次の操作に進んでください。 

 

メニューから [ Options > Play macro ] を選択し、YASARA インストールディレクトリ> mcr 内に保存されている

「md_analyze.mcr」を選択して実行します。 

 

解析が終了すると、解析結果がまとめられた HTML レポート(MacroTarget) _report.html が作成され、ブラウザで表示され

ます。ここでは、レポートの中から SMD の解析において有用な項目をいくつか抜粋してご紹介します。 

なお、出力ファイルの一般的な解析項目については、チュートリアルページ（https://www.affinity-science.com/yasara-tutorial/）

で公開している別のチュートリアル「分子動力学計算」の解析セクションも併せてご参照ください。 

 

 

https://www.affinity-science.com/yasara-tutorial/
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▪ Per-residue ligand interactions of the receptor：レセプター残基ごとの相互作用推移 

横軸にシミュレーション時間、縦軸にレセプターの残基番号をとった、相互作用の時系列プロットが記載されてい

ます。今回の例では、タンパク質 A 鎖（molecule A）について見てみると 23〜32 番、47〜50 番、81〜84 番付近の残

基がリガンドと相互作用していることが分かります。また、このプロットでは相互作用が消失したタイミングを確認

することもできます。リガンドが結合部位を脱出するためには、これらの残基との相互作用を順次断ち切る必要があ

り、これらが解離プロセスの障壁（エネルギーバリア）になっていると推測できます。   

 

 

▪ Interaction table：レセプター-リガンド間の相互作用一覧 

シミュレーション中に確認されたレセプター-リガンド間の相互作用を、頻度順に集計した表です。頻度の高い相互

作用ほど、そのリガンドの保持（または解離プロセスの障壁）に重要な役割を果たしている可能性が高く、主要な残

基を特定するのに役立ちます。 
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▪ Solute residue RMSF：溶質残基の RMSF 

このセクションでは、溶質（レセプタータンパク質）の各残基における RMSF（Root Mean Square Fluctuation：平均

二乗偏位）を確認できます。RMSF は値が高いほど、その残基がシミュレーション中に大きく動いた（柔軟性が高い）

ことを示します。 

今回の例では、タンパク質 A 鎖（青色）の 47～50 番付近に高いピークが見られます。これは、リガンドが結合部位

を脱出する際に、この領域が大きく動いて経路を作った可能性を示唆しています。なお、特定の部位だけでなくタン

パク質全体で異常に高い値を示している場合は、牽引力が強すぎたり、牽引方向が不適切だったりしたために、構造

全体が歪んでしまった可能性（アーティファクト）を考慮する必要があります。 

 

 

 

【Tips】RMSF を構造上に可視化する方法 

MD 解析用のマクロの 1 つである「md_analyzeres.mcr」マクロを実行すると、RMSF をタンパク質構造上の配色として視

覚化できます。手順は他のマクロと同様、対象となるマクロターゲットを指定して実行するだけです。実行後、タンパク質

は RMSF 値の大きさに応じたカラーマップで表示されます（下図参照）。 

今回の例（下図）では、リガンド近傍のループが黄色（高 RMSF 値）で強調されており、シミュレーション中にこの領域

が大きく動いたことが一目でわかります。この視覚的情報から、このループの動きがリガンドの解離プロセスに関与してい

る可能性を読み取ることができます。 

 

黄色で表示された部分はタンパク質 A 鎖の 47~50, 53 番目の残基 
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5. 参考情報 

5.1 ユーザーマニュアルについて 

 本チュートリアルは、ユーザーマニュアル（Help > Show user manual）の下記セクションを参考に作成しています。 

 

▪ Recipes - Perform complex tasks > Run a molecular dynamics simulation > Running a steered simulation  

 

こちらには、SMD (Steered Molecular Dynamics) シミュレーションの実行手順や実行時のヒントなど、参考となる情報が

まとめられていますので、本チュートリアルとあわせて参照することをお勧めします。 

 

 

5.2 マクロのパラメータ設定について 

5.2.1 マクロファイルの編集方法 

マクロファイルを編集することで、各種パラメータを設定・変更することがでます。以下の手順で編集してください。  

① マクロファイルの複製 

インストールフォルダ内に保存されているマクロファイル md_runsteered.mcr（インストールフォルダ> yasara > mcr 

> md_runsteered.mcr）をコピーし、適当なフォルダ（作業ディレクトリなど）にペーストして下さい。 

② マクロファイルの表示 

複製したマクロファイルをテキストエディタで開きます。（Windows であればメモ帳など）「＃」で始まる行はコメ

ントとなっており、処理は実行されません。マクロファイルの冒頭部分には概要が記載されています。その下の「=」

行で挟まれている部分がパラメータセクションとなっているので、計算条件などを変更する場合はここの内容を書き

換えます。 

③ 条件設定の変更 

変更したいパラメータを書き換えてください。各パラメータには、コメントで説明が記載されているので、内容を

確認しながら編集してください。（マクロ md_runsteered.mcr の主要パラメータについては、後述の【5.2.2 マクロの主

要パラメータ一覧】にまとめています。） 

④ マクロファイルの保存 

編集したファイルを上書き保存し、作業を終了します。（テキストファイルとして保存してしまった場合は、ファイ

ルの拡張子を「.mcr」に変更してください。）編集済マクロファイルは、オリジナルのファイルと混同しないようにフ

ァイル名を変更しておくとよいです。 

 

5.2.2 マクロの主要パラメータ一覧 

マクロファイル（md_runsteered.mcr）冒頭にあるパラメータセクション（「# ==== ~」で囲まれた部分）内では、主要なパ

ラメータを設定・変更することができます。 

 

パラメータ（マクロ内変数） 説明 デフォルト値 

ligandsel 
リガンドとして扱う残基や分子の選択。空欄の場合は自動認識を

試みる。 
'' (自動認識) 

receptorsel 
レセプターとして扱う残基の選択。リガンドを引っ張る方向の基

準となる。デフォルトではタンパク質が自動認識・設定される。 
'Protein' 

temperature シミュレーションを実行する温度 298K 

density 溶媒の密度 (g/ml)。水(298K)の場合は通常 0.997。 0.997 

solvent 溶媒密度の測定に使用される溶媒分子の名前。 'HOH' (水) 

acceleration 引っ張りの開始（最小）加速度 (pm/ps2)。 500.0 

accdelta 加速度の増分。0 に設定すると定加速度となる。 100 

pullstart 引っ張りを開始する時間 (ps)。これ以前は平衡化が行われる。 3 

ph 系全体の pH。アミノ酸の帯電状態に影響する。 7.4 
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ions 添加するイオンの種類と質量濃度。 'Na,Cl,0.9' 

tslist 
タイムステップ設定。分子内 1.25fs、分子間 2.5fs（2*1.25）が

一般的。 
2,1.25 

saveinterval スナップショットを保存する間隔 (fs)。 1000 

format トラジェトリの保存形式（sim, xtc, mdcrd）。 'sim' 

enddis 
シミュレーションを終了する、レセプターとリガンド間の距離 

(Å)。 
15 

longrange 長距離クーロン力（Particle-mesh Ewald など）の使用設定。 'Coulomb' 

ForceField（コマンド） 使用する力場。 AMBER14 

Cutoff（コマンド） 力のカットオフ距離 (Å)。 8 

SimSteps 
画面更新とペアリスト更新の間隔。1 にすると最も滑らかに力が

かかる。 
Screen=1,Pairlist=1 

 

 

5.3 牽引方向の定義について 

シミュレーション中、リガンドを引っ張る方向（牽引ベクトル）は固定された空間座標ではなく、タイムステップごとに

動的に再計算されます。これにより、シミュレーション中にレセプターが移動や回転をした場合でも、牽引方向がレセプタ

ーの座標変化に追従します。矢印オブジェクトの設定の有無に応じて、以下のように牽引方向が設定されます。 

※後述の【5.6 牽引方向のカスタマイズについて】の例のように、固定した牽引ベクトルを自身で指定した場合は、レセプ

ターの座標変化には影響せず、固定された空間方向に引っ張ります。 

 

▪ 方法 A 矢印オブジェクトを設定しない場合（デフォルトの動作）： 

マクロのデフォルト設定ではレセプターの重心からリガンドの重心へ向かう方向を引っ張り方向として自動的に計

算します。両重心位置を計算した後、レセプターの重心からリガンドの重心へ向かうベクトルを求め、それを距離で

割って正規化された単位ベクトルを生成します。 

 

▪ 方法 B 矢印オブジェクトを設定した場合（ユーザー指定の動作）： 

リガンドが特定のトンネルや経路を通って抜ける必要がある場合など、重心同士を結ぶ直線では不都合な場合に、

「Arrow（矢印）」オブジェクトを配置して引っ張り方向を明示できます。マクロ開始後、矢印オブジェクトを検知す

ると、矢印と同じ位置・向きに長いダミー原子のチェーン（直線状のグリッド）を作成します。そのダミー原子の直

線上（またはごく近傍）にあるレセプター側の原子を通常 20 個以上抽出し、リスト化します。これにより、「矢印の

方向を定義づけるレセプターの部分構造」が特定されます。シミュレーション中は、矢印オブジェクトそのものは削

除され、上記で特定した「レセプター原子のリスト」が形成する直線の向きが引っ張り方向として計算されます。シ

ミュレーションステップ毎に初期にマーキングした「レセプター原子のリスト」の現在の座標から直線のベクトルを

再計算します。 

 

処理の詳細については、マクロの以下のセクションをご参照ください。 

▪ 197~228 行目 

# If an arrow object is present it will be used to determine the steering direction 

▪ 265~306 行目 

# Run the steered simulation 

 

 

5.4 加速度による牽引と自動調整 

一般的な SMD シミュレーションでは仮想的なスプリングを用いた定速牽引や、一定の力を加え続ける定力牽引が主なア

プローチとして用いられていますが、YASARA の標準マクロではリガンドに加速度を適用して牽引する方式を採用してい
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ます。この方式の特徴は、リガンドを構成する各原子に対して力ではなく共通の加速度を直接適用する点にあります。これ

により原子ごとの質量の違いに関わらずリガンド全体が同調して動くようになります。その結果、一部の原子だけに無理な

負荷がかかって構造が歪むような内部ストレス（応力）を抑え、安定した牽引を実現できるのがメリットです。（SMD のシ

ミュレーションでは、選択した分子に一様な加速度を加えることができる Accel コマンドが使用されています。詳しくはユ

ーザーマニュアルのコマンドページをご参照ください。） 

 

また、SMD 用マクロ（md_runsteered.mcr）では、リガンドの移動距離や速度をモニタリングし、適切な加速度が与えられ

るように以下のような制御が行われています。 

 

▪ リガンドの移動が停滞した場合に加速度を増加 

シミュレーションの 400 ステップごとにリガンドの進捗を確認します。もしリガンドの最大移動距離（dismax）が

前回のチェック時（progdismax）から更新されていない場合、牽引力を強めるために加速度を段階的に加算します

（acceleration = acceleration + accdelta）。この制御により、強い水素結合や立体障害がある場所では、リガンドが動き出

すまで自動的に加速度を増加する（より強く引っ張る）処理が行われます。 

 

▪ 急激な加速を抑える速度制限 

リガンドが障壁を乗り越えた直後などに、蓄積された高い加速度によって異常な速度で飛び出してしまうことがあ

ります。これを防ぐため、マクロは 20 ステップごとに実際の移動速度を計算し、許容範囲（speedallowed パラメータ、

デフォルトは 4000 m/s）を超えた場合は加速度（引く力）を減少させます。 

 

これらの処理の詳細については、マクロの「# Get current steps per screen update to adjust the acceleration」セクションを併せ

てご参照ください。 

 

 

5.5 リガンドの移動距離（distance）の算出方法 

マクロファイル「md_runsteered.mcr」において、リガンドの移動距離はマクロ内変数 dis として計算されます。この値は、

シミュレーションの終了判定（enddis への到達）や、仕事量（Work）の計算、解析グラフの横軸として使用されます。 

移動距離はレセプター-リガンド間の相対的な変化量として計算されますが、矢印オブジェクト（Arrow）の使用有無によっ

て、算出方法が以下のように異なります。 

 

▪ 方法 A 矢印オブジェクトを設定しない場合（デフォルトの動作）： 

現在のレセプター重心とリガンド重心の間の距離を算出し、そこから初期距離を差し引いた値がリガンドの移動距

離（distance）となります。 

 

▪ 方法 B 矢印オブジェクトを設定した場合（ユーザー指定の動作）： 

矢印オブジェクトを設定した場合は、レセプター重心ではなく、前述の【5.3 牽引方向の定義について】に記載した

「レセプター原子のリスト」の重心とリガンドの重心の距離から、初期距離を差し引いた値がリガンドの移動距離

（distance）となります。 

 

 

5.6 牽引方向のカスタマイズについて 

 方法 A（矢印オブジェクトを設定しない場合）において、デフォルトの牽引方向（レセプターとリガンドの重心を結ぶ方

向）以外の独自の基準でリガンドを引っ張りたい場合、マクロファイル（md_runsteered.mcr）を編集することで、牽引方向

を定義するアルゴリズム自体をカスタマイズすることが可能です。 

 

マクロファイル「md_runsteered.mcr」をテキストエディタで開いて「direction from centers」と検索すると、次のようなセ

クションが見つかります。ここでは毎ステップ、重心間のベクトルから牽引方向（dir）を動的に計算しています。 
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# Calculate pulling direction from centers of mass, and 'dis'tance between receptor and ligand 

.  .  . 

disvec() = ligpos - recpos  # レセプター重心からリガンド重心へ向かう相対ベクトル 

dis = norm disvec        # ベクトルのノルム（距離）を計算 

.  .  . 

dir() = disvec / dis       # ベクトルを距離で除算し、長さを 1 に正規化 

 

独自の牽引アルゴリズムを定義したい場合、上記コードを適宜書き換えてください。 

例えば、「dir() = 0,0,1」と書き換えると、牽引方向を Z 軸方向に固定することができます。（dir() は長さ 1 の単位ベクトル

とする必要があります。） 

 

 

5.7 その他の参考資料 

 弊社ウェブサイトでは、分子動力学計算をはじめとする各種チュートリアルを公開しています。その他技術情報について

は、ブログ記事や FAQ もあわせてご参照ください。 

 

YASARA チュートリアル 

https://www.affinity-science.com/yasara-tutorial/ 

  

Affinity Science Blog/.org 

https://www.affinity-science.org/ 

 

YASARA よくある質問 

https://www.affinity-science.com/yasara-faq/ 
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