
1 

 

作成：2024年 11月 18日 

 

 

YASARA チュートリアル 

ループモデリング 
 

株式会社アフィニティサイエンス 
 

 

概要：YASARA Structure(Version24.10.5)による、タンパク質構造の欠損ループや欠損末端のモデリング方法について、チュ
ートリアル形式で説明します。 

 

1. はじめに 

 YASARAでは、BuildLoop コマンドを実行することで、タンパク質の欠損したループや末端をモデリングすることができます。ル

ープ（または末端）は、PDBの検索に基づいて適切なモデルが構築されます。本チュートリアルでは、ループと末端が欠損している

PDBファイル（PDB ID:2AC3）を読み込み、欠損箇所の構築、構造全体のリファインなどの操作を行います。 

 

1.1 本チュートリアルの流れ 

本チュートリアルの内容は以下になります。 

  

全体の流れ 

1 はじめに 

2 準備 

2.1 PDB ダウンロードと構造表示 

2.2 前処理（不要分子の削除） 

2.3 欠損残基の確認  

2.4 シーケンス（一文字コード）の取得 

2.5 欠損領域とアンカーの情報の整理 

3 欠損部位のモデリング（BuildLoop） 

3.1 ミッシングループのモデリング 

3.2 欠損した末端のモデリング 

4 モデリング部分の最適化（OptimizeLoop） 

4.1 クリーニング処理 

4.2 モデルの品質チェック（最適化前） 

4.3 モデリングしたループ・末端の最適化 

4.4 モデルの品質チェック（最適化後） 

5 構造全体のリファイン 

5.1 構造リファイン用マクロファイルの実行 

6 参考情報 
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2. 準備 

ループモデリングを行いたい構造を読み込み、簡単な前処理を行います。今回は、ヒトの Mnk2 キナーゼドメインの構造、PDB 

ID:2AC3の構造を使用します。 

 

2.1 PDB ダウンロードと構造表示 

メニューから File > Load > PDB file from Internet を選択し、PDB IDに「2AC3」と入力、右側の「Include residues only 

present in SEQRES」にチェックを入れて（任意）、PDFファイルをダウンロードすると、画面上にタンパク 3D構造が表示されます。 

 

  

Figure 2-1  PDBファイルのダウンロード 

 

「Include residues only present in SEQRES」を有効にすると、SEQRES レコード上に存在するものの構造中には存在しない残基を

含めて読み込まれます。無効のままでも問題ありませんが、この後の「2.3 欠損残基の確認」の際に便利なので、ここでは有効にして

おきます（LoadPDBコマンドの「SeqRes = Yes」オプションに該当します。）。 

すると、下の図のように、欠損している残基の Cαが水色の球で表現されます。 

 

 

Figure 2-2  SeqRes=Yesにより欠損残基の Cαが補完された構造 

 

2.2 前処理（不要分子の削除） 

この操作はループモデリング後でも問題ありませんが、ここで不要な分子を削除しておきます。右側の HUD「SCENE CONTENT」

からオブジェクトの内容を確認します。 

今回読み込んだオブジェクトは水分子のみが不要な分子として含まれているので、Edit > Delete > Waters を選択し、水分子を一

括削除します。 
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2.3 欠損残基の確認 

次に、欠損している残基番号を確認します。決まった方法はありませんが、いくつかの方法を以下にご紹介するので、これらを参

考に欠損している残基の番号を確認してください。 

 

❑ 「List」コマンドで確認する方法 

コマンドを使って操作するので、Space キーを押して、コンソール画面を開いてください。コンソール画面を開いたら、次のコマンド

を入力し、Enterキーを押して実行します。（※PDBファイルの読み込み時に、「Include residues only present in SEQRES」を有効に

していることが前提となります。） 

 

ListAtom CA Occupancy=0 

 

すると、以下のように欠損している残基（Occupancy＝０ の Cα原子）のリストが出力されます。 

 

Figure 2-3  ListAtomコマンド出力画面の一部 

 

確認してみると、232-250、306-309、370-385 の残基番号が欠損していることがわかります。（※残基番号 226-228 は実際には欠

損していないので、除いています。） 

 

（解説） 

PDBファイルの読み込み時に、「Include residues only present in SEQRES」を有効にしておくと、欠損している残基の情報も含め

て構造が表示されます。このとき、欠損している部分の残基は、Cα原子のみが水色の球として表示され、Occupancy の値は０に設

定されます。そのため、「List」コマンド（指定した原子や分子などをリスト表示するコマンド）で、Occupancy＝０ の Cα原子を出力す

ることで、欠損している残基をリスト表示することができます。 

なお、欠損していない残基でも、信頼性が低い場合に Occupancy が０に設定されている場合があり、リストに出力されることがあり

ます（今回の例では、残基番号 226-228）。この場合は、YASARA の 3D ビュー画面で構造を確認する、または、Bfactor 値が出力

されているか、PDB ファイル（テキストエディタで開くことができます）の「ZERO OCCUPANCY RESIDUES」の項目に記載されてい

るか等を確認して見分けてください。 

 

【Tips】不要分子が多数ある場合の処理方法 

 Edit > Select などから必要な分子を選択状態にしておき、Edit > Delete の選択ダイアログで Belongs to or has リストの

「Selected」を選択し、リスト下の「Negate attribute」にチェックを入れて有効にして OKをクリックすると、選択した分子以外を一括

削除できます。 
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❑ プロテインデータバンクで確認する方法 

RCSBプロテインデータバンク（https://www.rcsb.org/）にアクセスし、右上の検索窓に「2AC3」と入力して検索します。 

 

Figure 2-4  プロテインデータバンクの HP 

 

すると、PDB ID:2AC3のページが開くので、「Sequence」タブを選択すると、シーケンスの詳細情報を確認できます。上から４つ目

の「UNMODELED」の項目の、グレーの部分が欠損残基になります。グレーの部分にマウスオーバーすると、右上に該当する残基

の番号が表示されます。右端の「auth:~」が、YASARA内での残基番号と一致するので、こちらを控えておきます。 

 

Figure 2-5  Sequenceタブ 
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❑ PDBファイルで確認する方法 

前述の手順 3.1.2 で記載したように、RCSB プロテインデータバンクで PDB ID:2AC3 のページにアクセスします。右側にある

「Download Files」をクリック、「PDB Format」を選択し、PDBファイルをダウンロードします。 

 

Figure 2-6  PDBファイルのダウンロード   

 

次に、ダウンロードした PDB ファイルをメモ帳などのテキストエディタで開きます。Ctrl + F キーなどで「REMARK 465 MISSING 

RESIDUES」セクションを検索すると、欠損残基の情報が確認できるので、残基番号を控えておきます。 

 

Figure 2-7  PDBファイルの「REMARK 465 MISSING RESIDUES」セクション 
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❑ Sequence Selectorから確認する方法 

YASARAで PDBファイルをダウンロードする際に「Include residues only present in SEQRES」を有効にしていると、欠損残基の

配列情報も Sequence Selectorに表示されます。欠損残基（正確には Occupancy＝０の残基）は、グレーで表示され、二次構造情報

も欠けているので、ここから確認することもできます。（※残基番号 226-228は Occupancyが０のためグレーで表示されていますが、

欠損している訳ではないので注意してください。） 

「Include residues only present in SEQRES」を無効にして読み込んだ場合、残基番号が飛んでいる部分を探すことで欠損残基確

認することもできますが、末端が欠損している場合は確認できないので注意が必要です。 

 

 

Figure 2-8  Sequence Selectorの表示例（残基番号 306-309が欠損している） 

 

 

2.4 シーケンス（一文字コード）の取得 

アミノ酸配列は YASARA の Sequence Selector や PDB ファイルからも確認できますが、次のループモデリング実行時には欠損

配列をアミノ酸の一文字コードで指定するため、事前に一文字コードの配列情報を取得しておくとよいです。以下の例を参考に、

fastaファイルをダウンロードしたり、YASARAでアミノ酸の一覧を出力するなどして、配列情報を取得します。 

 

❑ fasta形式ファイルを取得する 

手順 2.3の「欠損残基の確認」を参考に、RCSBプロテインデータバンクのページから「Download Files」を選択、一番上の「Fasta 

Sequence」をクリックして fasta ファイルをダウンロードし、適当な場所に保存しておいてください。fasta ファイルはメモ帳などのテキス

トエディタで開くことができます。 

 

❑ YASARAでアミノ酸配列を出力する 

 SequenceRes コマンドを利用することで、アミノ酸配列を一文字コードで出力することができます。メニューから Analyze > 

Sequence of > Residueを選択し、右の Belongs to or has リストから AminoAcidを選択するなどして実行すると、コンソール画面に

配列が出力されます。（対象の選択については、モデルに応じて適宜対応してください。） 

 

Figure 2-9 SequenceRes コマンド出力例 

 

2.5 欠損領域とアンカーの情報の整理 

この後の欠損残基のモデリングには BuildLooop コマンドを実行しますが、その際に必要な情報をここで整理しておきます。コマ

ンドの実行時に必要な情報は、①開始と終了のアンカー（通常 2~3 残基分の残基番号と残基の一文字コード）と、②欠損配列（一

文字コード）、になります。 

先ほど取得したシーケンス情報を利用するなどして、欠損配列の文字列（一文字コード）や前後のアンカーを確認してください。 

 

（RCSBのサイトで PDB ID:2AC3のページを開き、「Structure」タブを開くと、配列情報が表示されます。欠損部分が灰色で表示さ

れているので、ここから欠損配列部分を確認することもできます。ただし、欠損配列だけではなく、構造情報があるものの占有率が 0

に設定されている残基（例：Res226-228）についても灰色で表示されるので注意してください。） 
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以下は、シーケンスの Fastaファイルを着色したものです。黄色がアンカー（アンカーには通常 2~3残基指定します）、灰色が欠損

配列となっています。 

 

3か所の欠損部分を整理すると、以下のようになります。()内は残基番号です。 

開始のアンカー 欠損配列 終了のアンカー 

…LGS (…Res 229,230,231) GIKLNGDCSPISTPELLTP (Res 232-250) CGS… (Res 251,252,253…) 

…CGW (…Res 303,304,305) DRGE (Res 306-309) ACP… (Res 310,311,312…) 

…WVQ (…Res 378,368,369) GCAPENTLPTPMVLQR (Res 370-385) なし 

Table 2-1 欠損領域と周囲のアンカー情報 

 

 

 

 

  

>2AC3_1|Chain A|MAP kinase-interacting serine/threonine kinase 2|Homo sapiens (9606) 

GSTDSFSGRFEDVYQLQEDVLGEGAHARVQTCINLITSQEYAVKIIEKQPGHIRSRVFREVEMLYQCQGHRNVLELIEFFE

EEDRFYLVFEKMRGGSILSHIHKRRHFNELEASVVVQDVASALDFLHNKGIAHRDLKPENILCEHPNQVSPVKICDFDLG

SGIKLNGDCSPISTPELLTPCGSAEYMAPEVVEAFSEEASIYDKRCDLWSLGVILYILLSGYPPFVGRCGSDCGWDRGEAC

PACQNMLFESIQEGKYEFPDKDWAHISCAAKDLISKLLVRDAKQRLSAAQVLQHPWVQGCAPENTLPTPMVLQR 
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3. 欠損部位のモデリング（BuildLoop） 

アミノ酸残基が欠損している部分の構造をモデリングしていきます。YASARAでは、BuildLoop コマンドを使ってミッシングループ

をモデリングすることができます。また、同じコマンドで、N末端や C末端の欠損箇所も構築することができます。 

それでは、手順 2.5で確認した 3か所の欠損部位を順にモデリングしていきます。 

 

3.1 ミッシングループのモデリング 

はじめに、BuilLoop コマンドの使用方法を紹介しながら、一つ目のミッシングループ、Res 232-250 部分を構築してみます。

BuilLoop コマンドは、PDB データベースから類似の構造を検索し、構造ファイルの欠損したループや末端をモデリングできるコマ

ンドです。（詳細は、ユーザーマニュアルの BuilLoopコマンドページに記載されているので、ご参照ください。） 

BuilLoop コマンドは、コンソールからコマンドで実行するほかに、メニューからも実行できるので、それぞれの実行方法を説明します。

どちらで実行しても基本的には同じ処理が行われるので、お好みの方法でモデリングしてください。 

 

実行前に、まずはミッシングループ「Res 232-250」の配列やアンカー部分の情報を整理しておきます。 

 

Figure 3-1 ミッシングループ「Res 232-250」の配列とアンカー 

 

まず、BuidLoopコマンドの実行時に必要な情報をまとめておきます。 

 

❑ ループ開始・終了のアンカー原子 

欠損配列と接続する部分の、バックボーンとなる原子をそれぞれ 3つ以上指定します。例えば、Figure 3-1のピンク色で示

したバックボーン原子や、黄色で示した C炭素などを指定します。 

 

 

 

【Note】PDBの即時検索の適用について 

アンカー原子に Figure 3-1のピンク色で示した末端 3つ分のバックボーン原子を選択（コマンドの場合は開始のアンカーを

「C-N-CA」、終了のアンカーを 「CA-C-N」の形式で指定）した場合、欠損部分が 17残基以内であれば PDBのクイックアクセス

インデックスを使用した即時検索が適用されます。ただし、他のバックボーン原子を指定した場合には、この即時検索は適用さ

れません。 
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以下に、コマンド実行時の指定例をいくつか示します。コマンドの入力例で記載しますが、メニューから実行する場合は、それ

ぞれ対応する原子を選択すればよいです。 

 

方法１） 即時検索が可能な指定例 （ピンク色で示した原子を指定） 

       開始アンカー原子：C Res 230 or N CA Res 231  終了アンカー原子：CA C Res 251 or N Res 252 

 

方法２） C炭素を 3つ指定した例（黄色でハイライトした原子を指定） 

開始アンカー原子：CA Res 229-231   終了アンカー原子：CA Res 251-253 

 

方法３） 2残基分のバックボーン原子をまとめて指定した例 

開始アンカー原子：Backbone Res 230-231  終了アンカー原子：Backbone Res 251-252 

 

❑ 欠損配列（アンカーを含む） 

欠損配列には、アンカーに指定した原子が属する残基を含めて一文字コードで指定します。残基の並びは、タンパク質全

体の N末端→C末端の配列の方向に合わせて入力します。（通常は残基番号が若い方から順に指定します。） 

今回の例では、欠損している Res 232-250の配列は、前に確認した通り「GIKLNGDCSPISTPELLTP」です。コマンド実行時

には、これにアンカーに指定した残基を加えて指定します。 

 

例えば、上記の方法１や方法３のようにアンカー原子を指定した場合は、アンカー原子が 2残基分に属しているので、それら

を含めて以下のように指定します。（黄色はアンカー残基） 

   GSGIKLNGDCSPISTPELLTPCG 

 

アンカー原子を方法２のように指定した場合は、アンカー原子が 3残基分に属しているので、以下のように欠損配列を指定し

ます。（黄色はアンカー残基） 

 LGSGIKLNGDCSPISTPELLTPCGS 

 

 

3.1.1 メニューから実行する場合 

それでは実際に、ループモデリングを実行します。まずは、メニューから一つ目のミッシングループ、Res 232-250部分を例に、ミ

ッシングループを構築する方法を説明します。 

 

❑ メニューから Edit > Build > Loop を選択 

 ループを構築したい場合は「Loop」、N末端を構築したい場合は「N-terminal loop」、C末端を構築したい場合は「C-

terminal loop」をそれぞれ選択します。今回は、ループを構築したいので、「Loop」を選択します。 

 

Figure 3-2 ループモデリングメニュー 
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❑ 開始アンカー原子の選択 

すると、アンカー原子の選択画面が表示されるので、ループ開始のアンカー原子（タンパク質の C末端側）を選択し

ます。指定方法は、前述の「3.1 ミッシングループのモデリング」を参照してください。ここでは例として、残基番号 229-

231の CA原子を指定し、アンカー原子を Ctrlキーを押しながら複数選択します。OKをクリックして次の画面に進みま

す。 

（表示されるダイアログには、N-terminal anchor と記載されていますが、欠損配列の N末端側アンカーという意味です。） 

 

  

Figure 3-3 (左) アンカー指定方法 2でα炭素を 3つ指定 (右) Name CA と残基番号を用いた指定例 

 

❑ 終了アンカー原子の選択 

開始アンカー原子と同じように、終了アンカーとなる残基番号 251-253の CA原子を指定し、OKをクリックします。 

  

Figure 3-4 (左) アンカー指定方法 2でα炭素を 3つ指定 (右) 残基番号 251-253の CA原子を指定した例 

 

❑ アンカーを含む欠損配列の入力とオプション設定 

「Sequence in one letter code…」で始まる入力欄に、欠損配列を一文字コードで入力します。アンカーの残基を含めるこ

とに注意し、前述の「3.1 ミッシングループのモデリング」を参考に指定してください。 

今回はアンカー原子が 3残基分に属しているので、以下のように入力します。（黄色はアンカー残基） 

 

LGSGIKLNGDCSPISTPELLTPCGS 

 

また、この画面からはオプションを指定できますが、ここではデフォルト設定のまま、OK をクリックし、モデリングを実行し

ます。オプションの詳細については、補足「6.2 BuildLoopコマンドのオプションについて」をご覧ください。 

画面に映っていませんが 

Res 229の CAも選択します 
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Figure 3-5 配列の入力とオプション設定例（前後 3残基をアンカーに指定した例） 

 

 

3.1.2 コマンドで実行する場合 

次に、2つ目のミッシングループ「Res 306-309」を例に、コマンドでの実行方法を説明します。前述したように、BuildLoopコマンド

は特定の形式でアンカー原子を指定すると PDB の即時検索が適用されるので、今回はこの形式で実行してみます。（メニューから

実行する際も、同様のアンカー原子を指定すれば即時検索を利用したモデリングが可能です。） 

欠損配列やアンカーについては手順 2.5でまとめていますので、そちらもご参照ください。 

 

 BuildLoopコマンドのフォーマットについて 

コマンドは、以下のフォーマットで実行します。 

※N末端を構築する場合は、①ループ開始のアンカーに「None」と入力します。 

※C末端を構築する場合は、③ループ終了のアンカーに「None」と入力します。 

 

①③のアンカー原子の指定方法、②の欠損配列の指定方法は、前述の「3.1 ミッシングループのモデリング」をご覧ください。 

④のオプションについては、補足「6.2BuildLoopコマンドのオプションについて」にまとめているのでそちらをご参照ください。 

 

以上より、Res 306-309のミッシングループを構築するコマンド例は以下のようになります。（黄色はアンカー残基） 

方法１ のコマンドは、PDBの即時検索が適用される形式になっているので、今回はこのコマンドを実行してみます。 

 

 

 コマンドの実行 

準備ができたら以下の手順でコマンドを実行し、ミッシングループを構築します。ここでは例として、PDB の即時検索が適用され

る方法（方法１）を実行してみます。 

 

❑ Spaceキーを押して、コンソール画面を開きます。 

❑ 下記のコマンド例をコピーするなどして、コンソール画面にコマンドを入力します。 

BuildLoop C Res 304 or N CA Res 305,GWDRGEAC,CA C Res 310 or N Res 311 

方法 1) BuildLoop C Res 304 or N CA Res 305,GWDRGEAC,CA C Res 310 or N Res 311 

方法 2) BuildLoop CA Res 303-305,CGWDRGEACP,CA Res 310-312 

方法 3) BuildLoop Backbone Res 304-305,GWDRGEAC,Backbone Res 310-311 

BuildLoop [①ループ開始のアンカー],[②欠損配列(アンカーを含む)],[③ループ終了のアンカー],[④オプション] 
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❑ Enterキーを押してコマンドを実行します。 

 

 

Figure 3-6 BuildLoopコマンド実行例 

 

実行すると、コンソール画面に採用された PDB 構造の ID が出力されます。この形式でアンカー原子を指定すると、短い時間でモ

デリングが可能です。 

 

 

3.2 欠損した末端のモデリング 

ミッシングループが構築できたら、続いて欠損している C 末端（Res 370-385）のモデリングを行います。N 末端や C 末端の欠損

についても、BuildLoop コマンドを使って同様の操作でモデリングができます。こちらもコンソールからコマンドで実行する方法と、メ

ニューから実行する方法を順に説明します。実行時の処理内容は基本的に同じなので、お好きな方で実行してください。 

欠損配列やアンカーについては、手順 2.5でまとめていますので、そちらを確認しながら進めてください。 

 

3.2.1 メニューから実行する場合 

基本的にはループモデリングと同じ操作になります。 

 

❑ メニューから Edit > Build > C-terminal loop を選択 

（N末端をモデリングしたい場合は、「N-terminal loop」を選択します。） 

 

❑ 開始アンカー原子の選択 

ループモデリング時と同様の指定方法で開始アンカー原子を選択します。（「N-terminal loop」を選択した場合は、終了

アンカー原子を選択します。） 

以下に、左図が残基番号 368-369のバックボーン原子を指定した例（PDBの即時検索が適用される指定方法）、右図

が残基番号 367-369の CA原子を指定した例をそれぞれ示します。 

 

Figure 3-7 (左) 残基番号 368-369のバックボーン原子を指定した例 (右) 残基番号 367-369の CA原子を指定した例 

 

❑ アンカーを含む欠損配列の入力とオプション設定 

ループモデリングの時と同じように、アンカーを含めて欠損残基の配列を入力し、今回もオプションはデフォルト設定の

まま OKをクリックしてモデリングを実行します。 

 

例１）  VQGCAPENTLPTPMVLQR （2残基分の開始アンカーを指定した場合） 

例２） WVQGCAPENTLPTPMVLQR （3残基分の開始アンカーを指定した場合） 

画面に映っていませんが 

Res 367の CAも選択します 
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Figure 3-8 配列の入力とオプション設定例（2残基分を開始アンカーに指定した例） 

 

 

 

3.2.2 コマンドで実行する場合 

基本的にはループモデリングと同じなので、手 3.1.2の「コマンドで実行する場合」と同様にコマンドを実行します。ただし、

今回は C末端側が欠損しており、終了のアンカー原子が存在しないため、その部分には「None」と指定します。 

（N末端側が欠損している場合は、開始のアンカー原子の指定部分を「None」とします。） 

以下がコマンド例になります（黄色部分はアンカー残基）。なお、例１のコマンド例は PDBの即時検索が適用される形式です。 

 

 

 

  

例１） BuildLoop C Res 368 or N CA Res 369,VQGCAPENTLPTPMVLQR,None  

例２） BuildLoop CA Res 367-369,WVQGCAPENTLPTPMVLQR,None 

例３） BuildLoop Backbone Res 368-369,VQGCAPENTLPTPMVLQR,None 
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4. モデリング部分の最適化（OptimizeLoop） 

 続いて、構築したモデル部分を最適化するコマンド、OptimizeLoop を実行し、モデルの品質向上を試みます。モデルの品質は、

Z-スコア（Checkコマンド）で比較してみます。 

 

4.1 クリーニング処理 

事前にクリーニング処理を行っておきます。以下の Cleanコマンドを実行し、不要な分子があれば削除しておきます。 

 

❑ Edit > Clean > All 

 

4.2 モデルの品質チェック（最適化前） 

これから OptimizeLoop コマンドを使って構築したループや末端のモデルを最適化しますが、実行前後のモデルの品質を比較し

たいので、Checkコマンドを使って最適化前のモデルの Z-スコアを確認しておきます。 

事前に力場を YASARA2に設定してから、Checkコマンドを使って現在のモデルの Z-スコアをチェックします。 

 

❑ Simulation > Force field を選択し、リストから「YASARA2」を選択して「OK, and~」をクリック 

 

Figure 4-1 力場の設定画面 

 

❑ Analyze > Check > All から、「ModelQuality:~」を選択し、OK 

 

Figure 4-2  Checkコマンドの実行画面 
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すると、コンソール画面に Z-スコアが出力されます。（アンカー原子の指定方法によって多少結果が異なる場合があり

ます。）この例では、最低化前の Z-スコアは -1.895 でした。- 

 

Figure 4-3 Z-スコアの確認① 

 

4.3 モデリングしたループ・末端の最適化 

続いて、OptimizeLoopコマンドを実行し、作成した欠損部位の最適化を行います。OptimizeLoopコマンドは、アンカー原子（と、

指定した場合は二次構造）を考慮して、指定した数の構造を PDBから抽出し、ループの最適化とエネルギー計算を行い、最もスコ

アが高かった構造が採用されます。BuildLoopコマンドの実行時と同じようにアンカー原子を指定して実行します。 

以下に、コマンドで実行する場合と、メニューから実行する場合の手順を順に紹介します。 

※先ほど設定したので操作を省略しますが、OptimizeLoop コマンド実行時は力場を YASARA2にしておくことが推奨されています。 

 

4.3.1 コマンドで実行する場合 

コマンドで実行する場合は、以下のようなフォーマットになります。 

 

 

 

①と②のアンカーは、BuildLoop コマンドと同じように指定します。また、BuildLoop コマンドと同様、開始のアンカーを「C-N-CA」、

終了のアンカーを 「CA-C-N」の形式で指定すると、欠損部分が 17残基以内であれば PDBのクイックアクセスインデックスを使用し

た即時検索が適用されます（メニューから実行する際も同様）。 

③のオプションでは、PDBから抽出するサンプル数と二次構造情報を指定できます。詳細は、ユーザーマニュアル

OptimizeLoopコマンドページをご参照ください。今回は、オプションを指定せずに実行します。（指定しない場合、サンプル数はデ

フォルトで 100に設定されます。） 

 

以下にコマンド例を示すので、先ほどモデリングした３つの欠損部分を最適化してみてください。この例ではアンカー原子には即時

検索が適用される形式を使用しています。 

 

 

 

 

 

4.3.2 GUI メニューから実行する場合 

メニューから実行する場合は、次の操作を行います。メニューから Edit > Optimize を選択し、ループの最適化を行いたい

場合は Loop を、N末端の場合は N-terminal loop、C末端の場合は C-terminal loopをそれぞれ選択します。 

 

1) ループ（Res 232-250）の最適化 

❑ メニューから、Edit > Optimize > Loop を選択 

❑ 開始アンカー原子の選択 

BuildLoopコマンドの実行時と同じように選択し、OKをクリック。（例：Res 230の C と Res 231 の N、CA） 

OptimizeLoop [①ループ開始のアンカー],[②ループ終了のアンカー], [③オプション] 

OptimizeLoop C Res 230 or N CA Res 231,CA C Res 251 or N Res 252 

OptimizeLoop C Res 304 or N CA Res 305,CA C Res 310 or N Res 311 

OptimizeLoop C Res 368 or N CA Res 369,None 
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Figure 4-4 開始アンカー原子の選択例 

 

❑ 終了アンカー原子の選択 

こちらも BuildLoopコマンドの実行時と同じように選択し、OKをクリック。（例：Res 251の CA、C と Res 252 の N） 

 

Figure 4-5 終了アンカー原子の選択例 

 

❑ オプション設定・実行 

次に、オプションの設定画面が開きます。「Samples」では PDBから抽出する構造の数を指定できるので、任意に変

更してください。コマンドから実行する場合のデフォルト値が 100なので、ここでは例として 100に設定し、OKをクリック

して実行します。今回は空欄のままにしていますが、下の欄には二次構造の情報を指定することもできます。 

 

Figure 4-6 オプション設定画面 
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2) ループ（Res 306-309）の最適化 

1)と同様に操作し、ループの最適化を行ってください。 

❑ メニューから、Edit > Optimize > Loop を選択 

❑ 開始アンカー原子の選択 （例：Res 304の C と Res 305 の N、CA） 

❑ 終了アンカー原子の選択 （例：Res 310の CA、C と Res 311 の N） 

❑ オプション設定・実行 （例：Samples数を 100に設定（任意）） 

 

3) C末端（Res 370-385）の最適化 

基本的には 1)と同じような操作になります。 

❑ メニューから、Edit > Optimize > C-terminal loop を選択 

❑ 開始アンカー原子の選択 （例：Res 368の C と Res 369 の N、CA） 

❑ オプション設定・実行 （例：Samples数を 100に設定（任意）） 

 

 

4.4 モデルの品質チェック（最適化後） 

 モデルの最適化が終了したら、再度 Z-スコアを確認してみます。 

 

❑ Analyze > Check > All から、「ModelQuality:~」を選択し、OK 

 

Figure 4-7 Z-スコアの確認② 

  

最適化により、Z-スコアが -1.895 から -1.326 に改善することができました。 

 

 

欠損したループや末端のモデリングの操作は以上となりますので、作成したモデルを File > Save asから保存して終了となります。 

Z-スコアをさらに改善したい場合は、そのまま次の手順「5構造全体のリファイン」に進んでください。 
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5. 構造全体のリファイン 

モデルのクオリティをさらに改善したい場合、主に次の 2 つの方法があります。1 つ目は、構造全体のエネルギー最小化計算を

行う方法で、2 つ目は、構造リファイン用の短い MD 計算マクロ（md_refine.mcr）を利用する方法です。短い時間で実行したい場合

は前者、時間をかけられる場合は後者を選択してください。 

前者のエネルギー最小化については、弊社のウェブサイトに日本語チュートリアルを公開していますので、そちらを参考に実行し

てください。（YASARA技術情報ページ https://www.affinity-science.com/yasara-tech/） 

ここでは、後者の構造リファイン用のマクロファイルを実行する方法を紹介します。 

 

5.1 構造リファイン用マクロファイルの実行 

YASARA には構造リファイン用の短いシミュレーション実行マクロ、md_refine.mcr が付属しています。このマクロを実行すると、

500 psのシミュレーションが行われ、25 psごとに PDBファイルが保存されます。さらに、各スナップショットのエネルギー値などを解

析した結果ファイル（.tabファイル）が作成されます。 

 

❑ 作業ディレクトリの作成 

マクロを実行するにあたり入出力ファイルを格納するディレクトリ（フォルダ）を新規に作成します（Windows ではエク

スプローラ、Linux では mkdir コマンド等を使用）。作成場所やファイル名は任意で問題ありませんが、YASARA 上で

表示が乱れるため、日本語を含まないようにしてください。 

 

❑ 構造ファイルの保存 

モデリングした構造ファイルを先ほど作成した作業ディレクトリに保存します。 

メニューの File > Save as > PDB fileから、保存するオブジェクト（2ac3）を選択して OK、Browseから先ほど作成した作

業ディレクトリを保存先に指定し、Filename欄に任意のファイル名（例：2ac3-model.pdb など）を指定して OK。 

※ファイル形式は、PDBファイル形式の他に YASARA Object形式ファイル（.yob）形式も利用できます。 

 

❑ マクロターゲットの指定 

メニューの Options > Macro&Movie > Set target から、マクロターゲットを設定します。 

作業ディレクトリから先ほどで保存した構造ファイル（例：2ac3-model.pdb など）を選択し、右側の Remove…オプション

の「file extension」にチェックを入れて拡張子を除外して指定します。 

 

❑ マクロファイルの実行 

メニューの Options > Macro&Muvie > Play macroから、md_refine.mcrを選んで OKをクリックすると、MD計算が

開始します。 

 

Figure 5-1 md_refine.mcr実行中画面 
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❑ 結果ファイルの確認 

シミュレーションが終了すると、マクロターゲットに指定した構造ファイルの保存先のフォルダに、 

(MacroTarget) _results.tab （例：2ac3-model_results.tab） 

という名前のタブ区切りテキストファイルが作成されます。このファイルを開くと、各スナップショットの解析結果を確認

できます。最終行には、最もエネルギーが低い構造のスナップショットの情報が記載されています。同じフォルダに、各

スナップショットの PDBファイルも保存されます。今回の実行例では、スナップショット 18のスコアが最もよかったので、

今回はこの構造を採用することとします。（2ac3-model_snapshot18.pdb） 

 

Figure 5-2 結果ファイルの出力例 

 

❑ 終了後：モデルのクオリティ（Z-スコア）の確認 

採用した構造について、再度 Checkコマンドを実行し、Z-スコアを確認してみます。 

一旦画面をクリア（Clear Sceneアイコン（   ）をクリック）し、先ほど採用した構造ファイルを開きます（File > Load > 

PDB file またはファイルをドラッグアンドドロップ）。続いて、Analyze > Check > All から、「ModelQuality:~」を選択し、

OKをクリック。 

 

コンソール画面を確認すると、Z-スコアは-0.365となり、マクロファイル実行前の-1.326から大幅に改善することができま

した。 

 

 

  

Figure 5-3 Z-スコアの確認③ 
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6. 参考情報 

6.1 SampleLoop コマンドを利用したモデリングについて 

 BuildLoop コマンドと似ているコマンドに、SampleLoop があります。BuildLoop は、欠損している部分のモデルを構築するコマンド

ですが、SampleLoopは、既に存在しているループ（や末端）について、異なるコンフォメーションを生成するコマンドです。  

SampleLoop は既存のループを分析するため、BuildLoop と異なり欠損配列の入力は不要で、OptimizeLoop のようにアンカー原子

を指定するだけで実行できます。実は、手順 2.1のように PDB ファイルの読み込み時に SeqResオプションを Yesに指定しておくと、

欠損残基の情報も含めて読み込まれるため、SampleLoopコマンドでも PDBファイルの欠損部分をモデリングすることができます。 

ただし、BuildLoop と SampleLoop を同じ条件で実行しても、同じ構造が得られるわけではないようです。（3 種類の PDB 構造を用

いて両者のコマンドを実行してテストしたところ、いずれも BuildLoopの方がわずかに高品質なモデルを生成しました。）欠損配列を

指定する必要がない分、SampleLoop コマンドを利用した方が簡単にモデリングを実行できますが、その点に留意してご利用くださ

い。コマンドの詳細については、YASARAのユーザーマニュアルをご参照ください。 

なお、YASARA ユーザーマニュアルの、LoadPDB コマンドページには、SampleLoop コマンドを利用し、自動で PDB ファイルの

欠損部分のモデリングと最適化（OptimizeLoop コマンド）を行うことができるマクロ例が記載されていますので、よろしければご参照

ください。 

 

6.2 BuildLoop コマンドのオプションについて 

 BuildLoop コマンドには、次のオプションがあります。（詳細については、YASARA ユーザーマニュアルのコマンドページもあわせ

てご参照ください。） 

オプション 指定内容 デフォルト値 

Structures 生成したいモデル数を指定します。 1 

Mutate 
All | None | MismatchAla | Ala から選択 

検索された PDB構造と指定した配列の間の一致・不一致の処理方法を指定します。 
All 

Bumpsum バックボーンのバンプの距離の合計が許容される最大値（Å）を指定します。 1.0 

SecStr 二次構造を指定します。略号：H（Helix）, E（Strand）, T（Turn）, C（Coil） 指定なし 

BridgeCys 

Yes | No で指定 

生成したループと周辺残基の間にシステインのジスルフィド（S-S）結合を形成するか

否かを指定します。 

Yes 

 

（補足） 

・Mutateオプション 

入力配列と検索されたデータベース配列の間の一致・不一致の場合の処理方法について、以下の表にまとめます。BuildLoop

コマンドでは、入力配列が不明な場合は「X」（未知のアミノ酸コード）を利用できます。一番右の列は、入力配列が Xの場合の処理

内容になります。 

入力配列：BuildLoopコマンド実行時に入力した、欠損残基の配列 

データベース配列：BuildLoopコマンド実行時に検索された PDBデータベースの配列 

Mutate 一致 不一致 不明（X）残基 

All 入力配列 入力配列 データベース配列 

None データベース配列 データベース配列 データベース配列 

Ala  アラニン（Ala） アラニン（Ala） アラニン（Ala） 

MismatchAla 入力配列 アラニン（Ala） データベース配列 

 

・BridgeCysオプション 

 「Yes」に設定して実行し、生成したループと周辺残基との間にジスルフィド結合が形成された場合、その後 OptimizeLoop コマンド

を実行するとジスルフィド結合が乱れる可能性があります。本チュートリアルの例ではジスルフィド結合が形成されないため、オプシ

ョンを設定しませんでしたが、OptimizeLoopコマンドを実行する予定がある場合には、「No」に設定することが推奨されています。 

 

・GUIのオプション設定画面 
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Figure 6-1  GUIのオプション設定画面 

 

6.3 ユーザーマニュアルの関連ページについて 

本チュートリアルで使用した各コマンドや操作の詳細については、YASARA ユーザーマニュアル（Help > Show user manual）の、

以下の項目をご覧ください。 

 

 関連コマンドページ 

Commands - Tell YASARA what to do > Index - All commands in alphabetic order >  

 ・ BuildLoop - Build central or terminal loop 

 ・ OptimizeLoop - Optimize central or terminal loop 

    ・ SampleLoop - Sample central or terminal loop 

 

 タンパク質構造のリファインについて 

Recipes - Perform complex tasks > Refine a protein model 

 

6.4 その他の参考資料 

エネルギー最小化や分子動力学計算など、弊社ウェブサイト（YASARA 技術情報）にて各種チュートリアルを公開しています。そ

の他技術情報については、ブログ記事や FAQもあわせてご参照ください。 

 

YASARA 技術情報 

https://www.affinity-science.com/yasara-tech/ 

  

Affinity Science Blog/.org 

https://www.affinity-science.org/ 

 

YASARAよくある質問 

https://www.affinity-science.com/yasara-faq/ 

以上 


